Multiple xS50 on a L513 (RS485)


  • administrators

    Hi,
    this really seems to be an issue on our part, probably related to the firmware of the extensions. You are not the only one having the exactly same problem (see https://forum.unipi.technology/topic/652/how-to-add-xs40-to-neuron-l203-using-custom-software/42). We will investigate it a bit more and let you know as soon as possible.

    Thank you for your patience,
    Martin



  • Ah.. okay. Well, at least I'm not crazy.
    Please let me know, I need to get this setup running asap.

    Thanks!


  • administrators

    Hi,
    ok, to get your setup running ASAP - would it be possible to use Teamviewer or direct SSH to the controller so we can check what's happening? We will check the extension's firmware version and do the FW update if neccessary.

    The best time would be between 12:00 and 20:00 CEST.

    Thanks,
    Martin



  • I can give you ssh access ? please mail me at robert at ropesolutions.nl, I will supply you the details.


  • administrators

    @salorob I just sent you the mail.



  • @martin-kudláček Just a quick question, since I also do have this problem with my xS50: Will there be some easy way to upgrade the firmware of the extension? What is the procedure of updating the firmware? Thanks for your answer!
    Regards,
    Boris


  • administrators

    @bsc101 The way to check and update the firmware is fairly easy - just connect the extension via RS485 to the controller, ssh into the controller and run a program. I will write down a tutorial how to do so. We just want to be extra sure, that this problem is tied down to the extension's firmware. I do apologize for this incovenience.



  • @martin-kudláček Sounds good, thanks for your efforts!


  • administrators

    Ok, the issue is definitely with the extension firmware 5.6. The current version is 5.18 and for some reason, both of you received extension units with the old firmware... We do apologize for this, if it is even possible.

    The @salorob was able to flash the firmware by his own via our Windows application tool. Unfortunately, the tool is also long time waiting for the update, so the firmware version in this tool is only 5.9, instead of 5.18.

    So the official hacker's tutorial is:

    1. SSH into your controller, the user "pi", the password (if not changed) is "raspberry". If your image is Raspbian, you need to install additional packages:
    pi@raspberrypi:~ $ sudo bash
    root@raspberrypi:/home/pi# echo "deb https://files.unipi.technology/debian stretch main" > /etc/apt/sources.list.d/unipi.list
    root@raspberrypi:/home/pi# wget -O - https://files.unipi.technology/debian/unipi_pub.gpg | apt-key add
    root@raspberrypi:/home/pi# apt update
    root@raspberrypi:/home/pi# apt install -y neuron-firmware neuron-modbus-tools
    
    1. Connect the extension to the controller over RS485. If you have multiple extensions, connect only one at a time. Right now, all of them thinks they have address 15, so you need to avoid collisions.

    2. Confirm, you have a connection to extension

    root@L503-sn101:/home/pi# /opt/neuron-bin/fwserial -p /dev/extcomm/0/0 
    Boardset:     5 E-14Ro_P-11DiR485              (v1.0)
    Baseboard:    2 E-14Ro                         (v1.0)
    Firmware: v5.6
    Modbus timeout set
    
    1. Flash the firmware
    root@L503-sn101:/opt/fw# /opt/neuron-bin/fwserial -p /dev/extcomm/0/0 -PR
    Boardset:     5 E-14Ro_P-11DiR485              (v1.0)
    Baseboard:    2 E-14Ro                         (v1.0)
    Firmware: v5.6
    Modbus timeout set
    Programming page 00 ...Finished programming chunk 0, ret: 64 err: 0
    Finished programming chunk 1, ret: 64 err: 0
    Finished programming chunk 2, ret: 64 err: 0
    Finished programming chunk 3, ret: 64 err: 0
    Finished programming chunk 4, ret: 64 err: 0
    Finished programming chunk 5, ret: 64 err: 0
    Finished programming chunk 6, ret: 64 err: 0
    Finished programming chunk 7, ret: 64 err: 0
    Page written OK.
    
    Programming page 01 ...Finished programming chunk 0, ret: 64 err: 0
    ..........
    
    1. Verify the firmware. Since the flashed firmware now accepts address set by DIP switches, you need to specify the address in the parameter -u. My extension has address 3
    root@L503-sn101:/opt/fw# /opt/neuron-bin/fwserial -p /dev/extcomm/0/0 -u 3
    Boardset:     5 E-14Ro_P-11DiR485              (v1.0)
    Baseboard:    2 E-14Ro                         (v1.0)
    Firmware: v5.18
    Modbus timeout set
    
    1. Repeat the process for all of the extensions

    Let me know, how it worked. If you don't want to flash the firmware yourself, let me know and we can arrange some remote session with you.

    Thanks,
    Martin



  • @martin-kudláček Thanks a lot, it works now :) I can set another address than default now!
    Firmware is now 5.9 (it was 5.6 as you said), is there any need to upgrade to 5.18?


  • administrators

    @bsc101 So I guess you used the Windows firmware update tool as @salorob. There are definitely a bugfixes from version 5.9 with some new functionality as well. You have the tutorial above, so you can update it, if you find out you need it.



  • This post is deleted!


  • @martin-kudláček My fault, did not do step 1 in your decsription above since fwserial and firmware files were already present. It's 5.18 now, thank you!