Remote programming, port forwarding



  • I am trying to remotely program the Neuron S103 with mervis and even though I have set the connection parameters in mervis (port) it says to me that the controller is only partially attached.

    Are there any other ports that need to be open other than 12346 (or whatever it is by default)
    (and port 80 for HMI)

    I have made a port forwarding from outside port 20000 to 12346 inside, and I can debug and connect just fine, but can't deploy solution.

    Do I need more ports open?


  • administrators

    @Iogo You could use the Mervis proxy for remote app deployment without the need of having any port opened. Check chapter 4.6 of the step by step. The only limitation is that you cannot change some parameters (IP address, proxy settings and some others) so you do not cut the connection to the PLC.



  • Well..the problem is that the proxy is disabled. The controller is 200km away, running just fine. Now I just would need to change some things in the program, without having to drive to the site.

    And the instructions about the whole proxy thing give me cold sweat.

    Whats this: Proxy ID - a unique ID string (Proxy ID)
    And where do I get it?

    Can I upload the configuration remotely if it says I am partially connected:
    Upload the configuration to UniPi and perform a device reboot

    What If I want to use TCP without proxy to upload new program?


  • administrators

    @Iogo That's exactly what the proxy is designed for. You have to test if you can upload the configuration (not by the broadcast, but by connection parameters) containing the proxy configuration.

    You either got a Mervis licence request or the licence itself. If you got the Licence request card, there is a guide how to obtain the licence from our web. The licence is set of proxy_id, db_username and db_password generated for you.


  • administrators

    @Iogo A little update. To make it work properly, you have to do a full attachment. To do this - select attach PLC, choose Use deploy parameters (expect that the fields are filled in correctly) then it should work ok.



  • Deploy parameters are correct, ip address, port, serial and controller type. Still complains about partial connection..but anyhow, if I want to use the proxy, which is it?

    Manual says on page 44: http://proxy.unipi.technology:6677

    And the default in mervis is: http://proxy.mervis.info:6677/

    Which is it? And if it is the http://proxy.unipi.technology:6677 it should be corrected in the mervis also to be default.

    Thanks.


  • administrators

    @Iogo And the attach process went well?

    Both proxy.unipi and proxy.mervis should work, but stick with the proxy.unipi which is in the manual.



  • Nothing went well.

    I have the proxy ID set, and I can debug the controller, so it means that I am connected but when I try to upload the changed parameters in proxy parameters it says:

    Controller is only partial attached, please attach against real controller.

    Host: IP-address of the controller
    Port: The port where the controller resides.
    Serial number: all zeros
    Device: Neuron S103.whatever

    Result: No go.

    So to speak, this is really starting to piss me off



  • Well, thanks to Tomas, got it working :) Thanks and sorry about the previous ranting :)


  • administrators

    @Iogo Would you mind sharing with us what exactly helped you? Was it the proxy settings Tomas mentioned?

    @tomas_hora Tomas, can you please explain, why the access to some public IP with forwarded port doesn't work? I'm experiencing similar problem - controller not fully attached - yet I am able to telnet to the IP and port from my computer.


  • administrators

    @Martin-Kudláček it works, but you have to attach using the "Use deploy parameters" as described a few posts above