Could not find temp sensors connected via 1-wire hub

  • Hi,

    not sure is this Mervis or HW issue, but I've recently purchased 2 temp sensors and 1-wire 8 port hub from the shop. I can't see temp sensors in Mervis if they are connected via 1-wire 8 port hub, but if I connect them directly to Neuron (m203) 1-wire port they do work (one by one of course).

    I have connected Neuron to hub via patch 5e cable (cable is checked, working), hub is shielded, on the hub itself it's stated port 1 is for IN, so patch cable is on port 1, two temp sensors are on ports 2 and 3.

    I configure Mervis the same way like for single temp sensor:

    • 1-wire channel added
    • build/deploy
    • PLC to commision mode
    • Discover temperature sensors returns empty list/table

    When I repeat the same with one temp sensor directly attached on 1-wire on Neuron, everything works OK.

    I've also tried to add 2 temp sensors and then to assign them, with the same results, via hub it's not working, directly yes.

    Do I need to do something else in Mervis, or any other advice?


  • administrators

    @dgajic Do you have the connection of the sensors and the 1wire line from Neuron correctly according to the schematics on the hub?

  • Port 1 on hub is marked as IN and I have patch cable there connected to 1-wire on Neuron.

    Temperature sensors are from the shop, I think they have only 4 pins wired (5-8), and they are connected to ports 2 and 3 of the hub.

    So, 3 ports on the hub used (1-3), first 1-wire to Neuron via patch cable and then 2 temp sensors.

    Is this correct?

  • Solved!

    I had to open 1 wire hub, there was a short circuit between pins 3 and 4 on port 8. After fixing that, everything is working OK.

  • administrators

    @dgajic Thanks a lot for the info. I am glad you figured it out. Also sorry for the issues!

Log in to reply

Looks like your connection to Forum was lost, please wait while we try to reconnect.