S103-G use GSM/GPRS module to connect to internet



  • @unix ok I have found the problem: replace \n with \r\n in both serial-in and serial-out nodes than it should work correctly! This has happen because when you have imported the flow I think you haven't already installed node-red-node-serial and the configuration got lost



  • @roberts_lando

    WTF great thx for fast response and help :smile:

    regards



  • @unix you welcome! :)



  • @roberts_lando said in S103-G use GSM/GPRS module to connect to internet:

    Hi!

    Great tutorial!

    I use Raspbian Stretch Lite and I can not get the S103-G to work with these instructions. The command cu -l / dev / ttyAMA0 crashes when I try to AT command. Ifconfig does not give ppp0.

    What have I missed?

    Vesa



  • @Vesa-Kauppinen
    Hi
    have you disable the BT on Pi3

    /boot/config.txt addline

    dtoverlay=pi3-disable-bt
    

    and on /boot/cmdline.txt remove

    serial console than its looks like

    dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=e13fdf55-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
    

    Regards



  • @unix

    Thank you for answer!

    BT disabled and cmdline.txt edited...

    No success

    @tomas_hora any ideas?

    Vesa



  • I always had compatibility problems when using Raspbian Stretch, try to use last Raspbian Jessie img and it should work



  • @roberts_lando

    Thank you for answer!

    Now i have tried with Rasbian Jessie Lite.....no success :disappointed:

    Do you use Jessie Lite or full?

    Thanks,
    Vesa



  • @Vesa-Kauppinen I think you have missed one or more step of the turorial. I suggest you to retry the tutorial and check if an instruction fails. Do you have switch on the GPRS module?



  • @roberts_lando Hi, I've done all the steps to configure the internet connection but when I type "ifconfig" it doesn't show me the ppp0 interface. Could you please help me?

    when I type the command "cat /var/log/syslog" It show me this messages:

    Sep 4 13:41:52 raspberrypi pppd[1698]: pppd 2.4.7 started by root, uid 0
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (BUSY)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (VOICE)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (NO CARRIER)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (NO DIALTONE)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (NO DIAL TONE)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (NO ANSWER)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (DELAYED)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (ERROR)
    Sep 4 13:41:52 raspberrypi chat[1702]: abort on (+CGATT: 0)
    Sep 4 13:41:52 raspberrypi chat[1702]: send (AT^M)
    Sep 4 13:41:52 raspberrypi chat[1702]: timeout set to 12 seconds
    Sep 4 13:41:52 raspberrypi chat[1702]: expect (OK)
    Sep 4 13:42:04 raspberrypi chat[1702]: alarm
    Sep 4 13:42:04 raspberrypi chat[1702]: Failed
    Sep 4 13:42:04 raspberrypi pppd[1698]: Connect script failed
    Sep 4 13:42:10 raspberrypi OWFS[477]: DEFAULT: ow_reconnect.c:(72) DS2482-100 bus master reconnected
    Sep 4 13:42:30 raspberrypi OWFS[477]: DEFAULT: ow_reconnect.c:(72) DS2482-100 bus master reconnected