xs30 not working

  • I have a Neuron L403 paired via RS485 to a xS30.

    The L403 works fine. How do I setup a channel to the xS30? I already tried a ModBus, Serial channel on "modbus.Neuron ..." with various settings. But it did not work.

    Is there any document for the micro switch magic of the xS30?


  • administrators

    @c0fec0de First of all I am sorry that the documentation for Extensions is not ready yet.

    Your approach great but you did not have the required information. If you have all the DIP switches on the extension Off (Up) it will be using softawe predefined communication parameters: 19200 bps, no parity, address 15.

    So if you select the comm speed of the Serial Modbus channel to 19200 and add the xS30 prototype with address 15, while having all configuration switches Off, you should be able to communicate.

    Not needed, just for info: The parity cannot be set from the IDE and has to be configured using the Modbus Registers (or variable UART_config in mervis while in Debug mode). Description of the register in the documentation.

  • Hello again,

    thanks for the clarification. I'll try ASAP

    At the end of the day, I have two xS30 on the Modbus.
    So I need to use the DIP switches:

    • What does N/E? In which position is N and in which E. By default all switches are "up".
    • In which position is 19200 for the 19.2/9.6 switch? "up" == 19200

    I assume to have to configure the first xS30 to address 1 and the second to address 2.
    What are the proper modbus settings when all other DIP switches are in default state? 19200, no parity, one stopbit?

    Do I need to run the xS30 through a power cycle after changing the DIP switches?

    Does the xS30 need a power cycle at reboot of the L403?

    Thanks for your help

  • administrators

    @c0fec0de E/N stands for the parity as Even or None. In your case there might be a small bug in the firmware so the meaning might be switched. So Up can be None and Down can be Even. The same is for the speed settings.

    You should set both to different addresses and then set 19.2/9.6 DOWN (On) and E/N UP(off) restart it (power cycle) and you should be able to communicate using 19200 without parity.

Log in to reply