Patron stucked after some hours



  • Hi everyone. I have many Patron units out there, seems that after some hours or at most a day they gets stuck. I have checked the RAM/CPU usage, network status, I/O status and I cannot identify the root cause of the problem. Does anyone know what could be the root cause of this?

    When I say stuck I mean I cannot connect it via ssh or webserver, before getting completely stucked it starts becoming slow. Suggestions?



  • Hi,

    I just received similar report from customer. Some hours or days and device stops responding to ping. Would be very interesting to find out what the problem is.

    Unfortunately my devices don't have connection to outside world, they are on small private LAN so I cannot check any logs easily.




  • administrators

    Hi everyone,
    this issue is new to us, although we have experienced some performance issues with our kernel module - it might be related to what you are experiencing. I have contacted both of you over email with more details.

    Thank you and have a nice day,
    Martin



  • @Martin-Kudláček After the upgrade with latest firmware the stucked problem is solved but now RS485 ports are no longer working and keep return timeout error.

    Any updates?


  • administrators

    Hello everyone,
    we have just released updated Zulu kernel, which solves this particular problem.

    The problem has been in the memory lock, which overused the swap, even when the swap is off on all our OS images. This has been fixed in kernel 5.10.17+. The new kernel is 5.10.35.

    Whole suite of OS images is currently being generated and within an hour uploaded to the Download section

    Thank you for reporting the issue nad have a nice day,
    Martin @ Unipi


Log in to reply