Disable unipi modbus tcp service



  • Hi, I have disable evok and mervis from the axon web interface but the unipi tcp service is still up.

     session-29.scope                                                                               loaded active running   Session 29 of user unipi                                                                
    unipicheck.service                                                                             loaded active exited    Check Unipi/Neuron/Axon version                                                         
    unipihostname.service                                                                          loaded active exited    Set default hostname on Neuron and Axon                                                 
    unipitcp.service                                                                               loaded active running   Unipi Neuron/Axon Modbus/Tcp Server                                                     
    user-1000.slice                                                                                loaded active active    User Slice of unipi                                                                     
    unipispi.target                                                                                loaded active active    Neuron/Axon Target                                                                    
    

    I have disabled it using sudo systemctl disable unipitcp.service, I think there should be a way to disable it using the web interface or disable it when disabling evok/mervis

    I also would like to know what is unipispi.target service used for and also unipicheck.service and If I can disable them If I'm not using mervis


  • administrators

    @roberts_lando The unipispi and unipicheck are common launchers of Neuron/Axons jobs (hostname generation, certain steps to setup some certain models, optional auto firmware upgrade, ... and running the unipitcp service). Check the /etc/systemd/system/unipispi.target.wants/

    The unipitcp is a common interface and listens only on the local loopback so its not a security issue. If you do not use it, it it actually does not do anything



  • @tomas_hora it's not a security issue but as I'm using another plc runtime with a local modbus tcp master running on port 502 unipitcp service was blocking it. I have disabled it and modbus has started working correctly