Setup evok on clean and updated 2019-04-08-raspbian-stretch-lite.img



  • Last day i destroyed my running UniPian-Neuron-OS-2019-01-07-v1.9 with an apt update and apt upgrade.
    The evok service didn't start again after issuing this commands.

    Now i try to reinstall from clean raspbian stretch lite image and there seems to be the same issue (manual from github)

    What is wrong here? How to make a clean setup?
    And how to keep the all time running network device up to date???

    Now i will go for the old UniPian Image and not execute the apt upgrade command :(

    And here are the outputs from the setup commands:

    login as: pi
    pi@192.168.13.25's password:
    Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l
    
    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    
    SSH is enabled and the default password for the 'pi' user has not been changed.
    This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.
    
    pi@raspberrypi:~ $ sudo su
    root@raspberrypi:/home/pi# passwd pi
    Enter new UNIX password:
    Retype new UNIX password:
    passwd: password updated successfully
    root@raspberrypi:/home/pi# exit
    pi@raspberrypi:~ $ sudo reboot
    login as: pi
    pi@192.168.13.25's password:
    Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l
    
    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Fri Sep 13 17:43:57 2019 from 192.168.13.23
    pi@raspberrypi:~ $ sudo apt update
    Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
    Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
    Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
    Get:4 http://archive.raspberrypi.org/debian stretch/main armhf Packages [221 kB]
    Get:5 http://archive.raspberrypi.org/debian stretch/ui armhf Packages [45.0 kB]
    Get:6 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages [56.9 kB]
    Get:7 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages [95.5 kB]
    Fetched 12.1 MB in 41s (290 kB/s)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    43 packages can be upgraded. Run 'apt list --upgradable' to see them.
    pi@raspberrypi:~ $ sudo apt upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be upgraded:
      base-files dbus gettext-base libdbus-1-3 libexpat1 libglib2.0-0 libglib2.0-data libicu57 libnghttp2-14 libpam-systemd
      libpng-dev libpng-tools libpng16-16 libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0
      libssh2-1 libssl1.0.2 libssl1.1 libsystemd0 libudev1 libwbclient0 openssh-client openssh-server openssh-sftp-server
      openssl patch raspberrypi-bootloader raspberrypi-kernel raspi-config rsync samba-common ssh systemd systemd-sysv
      tzdata udev unzip usbutils vim-common vim-tiny xxd
    43 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 95.8 MB of archives.
    After this operation, 7,886 kB of additional disk space will be used.
    Do you want to continue? [Y/n]
    Get:1 http://archive.raspberrypi.org/debian stretch/main armhf libraspberrypi-doc armhf 1.20190819~stretch-1 [31.4 MB]
    Get:2 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf base-files armhf 9.9+rpi1+deb9u11 [67.7 kB]
    Get:3 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf dbus armhf 1.10.28-0+deb9u1 [192 kB]
    Get:4 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libdbus-1-3 armhf 1.10.28-0+deb9u1 [176 kB]
    Get:7 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libpam-systemd armhf 232-25+deb9u12 [175 kB]
    Get:5 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libexpat1 armhf 2.2.0-2+deb9u2 [62.3 kB]
    Get:6 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf systemd-sysv armhf 232-25+deb9u12 [82.5 kB]
    Get:9 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf systemd armhf 232-25+deb9u12 [2,222 kB]
    Get:8 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libsystemd0 armhf 232-25+deb9u12 [259 kB]
    Get:10 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf udev armhf 232-25+deb9u12 [1,072 kB]
    Get:11 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libudev1 armhf 232-25+deb9u12 [121 kB]
    Get:17 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf openssh-client armhf 1:7.4p1-10+deb9u7 [701 kB]
    Get:26 http://mirror.chaoticum.net/rpi/raspbian stretch/main armhf libglib2.0-0 armhf 2.50.3-2+deb9u1 [2,527 kB]
    Get:12 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libwbclient0 armhf 2:4.5.16+dfsg-1+deb9u1 [121 kB]
    Get:19 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf tzdata all 2019b-0+deb9u1 [275 kB]
    Get:14 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf openssh-sftp-server armhf 1:7.4p1-10+deb9u7 [32.9 kB]
    Get:16 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf openssh-server armhf 1:7.4p1-10+deb9u7 [301 kB]
    Get:18 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf ssh all 1:7.4p1-10+deb9u7 [189 kB]
    Get:30 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf libpng-tools armhf 1.6.28-1+deb9u1 [130 kB]
    Get:13 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf samba-common all 2:4.5.16+dfsg-1+deb9u1 [174 kB]
    Get:15 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libssl1.0.2 armhf 1.0.2s-1~deb9u1 [899 kB]
    Get:31 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf libpng-dev armhf 1.6.28-1+deb9u1 [232 kB]
    Get:20 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libssl1.1 armhf 1.1.0k-1~deb9u1 [1,117 kB]
    Get:34 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf openssl armhf 1.1.0k-1~deb9u1 [712 kB]
    Get:23 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf vim-common all 2:8.0.0197-4+deb9u3 [159 kB]
    Get:29 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libnghttp2-14 armhf 1.18.1-1+deb9u1 [68.1 kB]
    Get:32 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libpng16-16 armhf 1.6.28-1+deb9u1 [263 kB]
    Get:21 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf vim-tiny armhf 2:8.0.0197-4+deb9u3 [338 kB]
    Get:36 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf unzip armhf 6.0-21+deb9u2 [151 kB]
    Get:22 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf xxd armhf 2:8.0.0197-4+deb9u3 [132 kB]
    Get:24 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf gettext-base armhf 0.19.8.1-2+deb9u1 [117 kB]
    Get:25 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf patch armhf 2.7.5-1+deb9u2 [99.6 kB]
    Get:27 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libglib2.0-data all 2.50.3-2+deb9u1 [2,518 kB]
    Get:28 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libicu57 armhf 57.1-6+deb9u3 [7,425 kB]
    Get:33 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libssh2-1 armhf 1.7.0-1+deb9u1 [126 kB]
    Get:35 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf rsync armhf 3.1.2-1+deb9u2 [356 kB]
    Get:37 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf usbutils armhf 1:007-4+deb9u1 [226 kB]
    Get:38 http://archive.raspberrypi.org/debian stretch/main armhf libraspberrypi-dev armhf 1.20190819~stretch-1 [407 kB]
    Get:39 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-kernel armhf 1.20190819~stretch-1 [35.4 MB]
    Get:40 http://archive.raspberrypi.org/debian stretch/main armhf libraspberrypi-bin armhf 1.20190819~stretch-1 [338 kB]
    Get:41 http://archive.raspberrypi.org/debian stretch/main armhf libraspberrypi0 armhf 1.20190819~stretch-1 [843 kB]
    Get:42 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-bootloader armhf 1.20190819~stretch-1 [3,581 kB]
    Get:43 http://archive.raspberrypi.org/debian stretch/ui armhf raspi-config all 20190423 [20.4 kB]
    Fetched 95.8 MB in 4min 36s (347 kB/s)
    Reading changelogs... Done
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 34734 files and directories currently installed.)
    Preparing to unpack .../base-files_9.9+rpi1+deb9u11_armhf.deb ...
    Unpacking base-files (9.9+rpi1+deb9u11) over (9.9+rpi1+deb9u8) ...
    Setting up base-files (9.9+rpi1+deb9u11) ...
    Installing new version of config file /etc/debian_version ...
    (Reading database ... 34734 files and directories currently installed.)
    Preparing to unpack .../0-dbus_1.10.28-0+deb9u1_armhf.deb ...
    Unpacking dbus (1.10.28-0+deb9u1) over (1.10.26-0+deb9u1) ...
    Preparing to unpack .../1-libdbus-1-3_1.10.28-0+deb9u1_armhf.deb ...
    Unpacking libdbus-1-3:armhf (1.10.28-0+deb9u1) over (1.10.26-0+deb9u1) ...
    Preparing to unpack .../2-libexpat1_2.2.0-2+deb9u2_armhf.deb ...
    Unpacking libexpat1:armhf (2.2.0-2+deb9u2) over (2.2.0-2+deb9u1) ...
    Preparing to unpack .../3-systemd-sysv_232-25+deb9u12_armhf.deb ...
    Unpacking systemd-sysv (232-25+deb9u12) over (232-25+deb9u9) ...
    Preparing to unpack .../4-libpam-systemd_232-25+deb9u12_armhf.deb ...
    Unpacking libpam-systemd:armhf (232-25+deb9u12) over (232-25+deb9u9) ...
    Preparing to unpack .../5-libsystemd0_232-25+deb9u12_armhf.deb ...
    Unpacking libsystemd0:armhf (232-25+deb9u12) over (232-25+deb9u9) ...
    Setting up libsystemd0:armhf (232-25+deb9u12) ...
    (Reading database ... 34734 files and directories currently installed.)
    Preparing to unpack .../systemd_232-25+deb9u12_armhf.deb ...
    Unpacking systemd (232-25+deb9u12) over (232-25+deb9u9) ...
    Preparing to unpack .../udev_232-25+deb9u12_armhf.deb ...
    Unpacking udev (232-25+deb9u12) over (232-25+deb9u9) ...
    Preparing to unpack .../libudev1_232-25+deb9u12_armhf.deb ...
    Unpacking libudev1:armhf (232-25+deb9u12) over (232-25+deb9u9) ...
    Setting up libudev1:armhf (232-25+deb9u12) ...
    (Reading database ... 34734 files and directories currently installed.)
    Preparing to unpack .../00-libwbclient0_2%3a4.5.16+dfsg-1+deb9u1_armhf.deb ...
    Unpacking libwbclient0:armhf (2:4.5.16+dfsg-1+deb9u1) over (2:4.5.16+dfsg-1) ...
    Preparing to unpack .../01-samba-common_2%3a4.5.16+dfsg-1+deb9u1_all.deb ...
    Unpacking samba-common (2:4.5.16+dfsg-1+deb9u1) over (2:4.5.16+dfsg-1) ...
    Preparing to unpack .../02-openssh-sftp-server_1%3a7.4p1-10+deb9u7_armhf.deb ...
    Unpacking openssh-sftp-server (1:7.4p1-10+deb9u7) over (1:7.4p1-10+deb9u6) ...
    Preparing to unpack .../03-libssl1.0.2_1.0.2s-1~deb9u1_armhf.deb ...
    Unpacking libssl1.0.2:armhf (1.0.2s-1~deb9u1) over (1.0.2r-1~deb9u1) ...
    Preparing to unpack .../04-openssh-server_1%3a7.4p1-10+deb9u7_armhf.deb ...
    Unpacking openssh-server (1:7.4p1-10+deb9u7) over (1:7.4p1-10+deb9u6) ...
    Preparing to unpack .../05-openssh-client_1%3a7.4p1-10+deb9u7_armhf.deb ...
    Unpacking openssh-client (1:7.4p1-10+deb9u7) over (1:7.4p1-10+deb9u6) ...
    Preparing to unpack .../06-ssh_1%3a7.4p1-10+deb9u7_all.deb ...
    Unpacking ssh (1:7.4p1-10+deb9u7) over (1:7.4p1-10+deb9u6) ...
    Preparing to unpack .../07-tzdata_2019b-0+deb9u1_all.deb ...
    Unpacking tzdata (2019b-0+deb9u1) over (2019a-0+deb9u1) ...
    Preparing to unpack .../08-libssl1.1_1.1.0k-1~deb9u1_armhf.deb ...
    Unpacking libssl1.1:armhf (1.1.0k-1~deb9u1) over (1.1.0j-1~deb9u1) ...
    Preparing to unpack .../09-vim-tiny_2%3a8.0.0197-4+deb9u3_armhf.deb ...
    Unpacking vim-tiny (2:8.0.0197-4+deb9u3) over (2:8.0.0197-4+deb9u1) ...
    Preparing to unpack .../10-xxd_2%3a8.0.0197-4+deb9u3_armhf.deb ...
    Unpacking xxd (2:8.0.0197-4+deb9u3) over (2:8.0.0197-4+deb9u1) ...
    Preparing to unpack .../11-vim-common_2%3a8.0.0197-4+deb9u3_all.deb ...
    Unpacking vim-common (2:8.0.0197-4+deb9u3) over (2:8.0.0197-4+deb9u1) ...
    Preparing to unpack .../12-gettext-base_0.19.8.1-2+deb9u1_armhf.deb ...
    Unpacking gettext-base (0.19.8.1-2+deb9u1) over (0.19.8.1-2) ...
    Preparing to unpack .../13-patch_2.7.5-1+deb9u2_armhf.deb ...
    Unpacking patch (2.7.5-1+deb9u2) over (2.7.5-1+deb9u1) ...
    Preparing to unpack .../14-libglib2.0-0_2.50.3-2+deb9u1_armhf.deb ...
    Unpacking libglib2.0-0:armhf (2.50.3-2+deb9u1) over (2.50.3-2) ...
    Preparing to unpack .../15-libglib2.0-data_2.50.3-2+deb9u1_all.deb ...
    Unpacking libglib2.0-data (2.50.3-2+deb9u1) over (2.50.3-2) ...
    Preparing to unpack .../16-libicu57_57.1-6+deb9u3_armhf.deb ...
    Unpacking libicu57:armhf (57.1-6+deb9u3) over (57.1-6+deb9u2) ...
    Preparing to unpack .../17-libnghttp2-14_1.18.1-1+deb9u1_armhf.deb ...
    Unpacking libnghttp2-14:armhf (1.18.1-1+deb9u1) over (1.18.1-1) ...
    Preparing to unpack .../18-libpng-tools_1.6.28-1+deb9u1_armhf.deb ...
    Unpacking libpng-tools (1.6.28-1+deb9u1) over (1.6.28-1) ...
    Preparing to unpack .../19-libpng-dev_1.6.28-1+deb9u1_armhf.deb ...
    Unpacking libpng-dev:armhf (1.6.28-1+deb9u1) over (1.6.28-1) ...
    Preparing to unpack .../20-libpng16-16_1.6.28-1+deb9u1_armhf.deb ...
    Unpacking libpng16-16:armhf (1.6.28-1+deb9u1) over (1.6.28-1) ...
    Preparing to unpack .../21-libraspberrypi-doc_1.20190819~stretch-1_armhf.deb ...
    Unpacking libraspberrypi-doc (1.20190819~stretch-1) over (1.20190401-1) ...
    Preparing to unpack .../22-libraspberrypi-dev_1.20190819~stretch-1_armhf.deb ...
    Unpacking libraspberrypi-dev (1.20190819~stretch-1) over (1.20190401-1) ...
    Preparing to unpack .../23-raspberrypi-kernel_1.20190819~stretch-1_armhf.deb ...
    Adding 'diversion of /boot/{........} to /usr/share/rpikernelhack/{....} by rpikernelhack'
    Unpacking raspberrypi-kernel (1.20190819~stretch-1) over (1.20190401-1) ...
    run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.14.98+ /boot/kernel.img
    run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.14.98-v7+ /boot/kernel7.img
    Preparing to unpack .../24-libraspberrypi-bin_1.20190819~stretch-1_armhf.deb ...
    Unpacking libraspberrypi-bin (1.20190819~stretch-1) over (1.20190401-1) ...
    Preparing to unpack .../25-libraspberrypi0_1.20190819~stretch-1_armhf.deb ...
    Unpacking libraspberrypi0 (1.20190819~stretch-1) over (1.20190401-1) ...
    Preparing to unpack .../26-raspberrypi-bootloader_1.20190819~stretch-1_armhf.deb ...
    Adding 'diversion of /boot/{........} to /usr/share/rpikernelhack/{....} by rpikernelhack'
    Unpacking raspberrypi-bootloader (1.20190819~stretch-1) over (1.20190401-1) ...
    Preparing to unpack .../27-libssh2-1_1.7.0-1+deb9u1_armhf.deb ...
    Unpacking libssh2-1:armhf (1.7.0-1+deb9u1) over (1.7.0-1) ...
    Preparing to unpack .../28-openssl_1.1.0k-1~deb9u1_armhf.deb ...
    Unpacking openssl (1.1.0k-1~deb9u1) over (1.1.0j-1~deb9u1) ...
    Preparing to unpack .../29-rsync_3.1.2-1+deb9u2_armhf.deb ...
    Unpacking rsync (3.1.2-1+deb9u2) over (3.1.2-1+deb9u1) ...
    Preparing to unpack .../30-unzip_6.0-21+deb9u2_armhf.deb ...
    Unpacking unzip (6.0-21+deb9u2) over (6.0-21) ...
    Preparing to unpack .../31-usbutils_1%3a007-4+deb9u1_armhf.deb ...
    Unpacking usbutils (1:007-4+deb9u1) over (1:007-4) ...
    Preparing to unpack .../32-raspi-config_20190423_all.deb ...
    Unpacking raspi-config (20190423) over (20190219) ...
    Setting up libwbclient0:armhf (2:4.5.16+dfsg-1+deb9u1) ...
    Setting up libexpat1:armhf (2.2.0-2+deb9u2) ...
    Setting up libnghttp2-14:armhf (1.18.1-1+deb9u1) ...
    Processing triggers for mime-support (3.60) ...
    Setting up xxd (2:8.0.0197-4+deb9u3) ...
    Setting up libpng16-16:armhf (1.6.28-1+deb9u1) ...
    Processing triggers for install-info (6.3.0.dfsg.1-1+b1) ...
    Setting up libpng-tools (1.6.28-1+deb9u1) ...
    Setting up tzdata (2019b-0+deb9u1) ...
    
    Current default time zone: 'Europe/London'
    Local time is now:      Fri Sep 13 17:54:45 BST 2019.
    Universal Time is now:  Fri Sep 13 16:54:45 UTC 2019.
    Run 'dpkg-reconfigure tzdata' if you wish to change it.
    
    Setting up libglib2.0-0:armhf (2.50.3-2+deb9u1) ...
    No schema files found: doing nothing.
    Setting up unzip (6.0-21+deb9u2) ...
    Setting up raspberrypi-bootloader (1.20190819~stretch-1) ...
    Removing 'diversion of /boot/{........} to /usr/share/rpikernelhack/{....} by rpikernelhack'
    Setting up samba-common (2:4.5.16+dfsg-1+deb9u1) ...
    Setting up gettext-base (0.19.8.1-2+deb9u1) ...
    Setting up usbutils (1:007-4+deb9u1) ...
    Setting up libicu57:armhf (57.1-6+deb9u3) ...
    Setting up rsync (3.1.2-1+deb9u2) ...
    Setting up raspi-config (20190423) ...
    Setting up libssl1.0.2:armhf (1.0.2s-1~deb9u1) ...
    Setting up libssh2-1:armhf (1.7.0-1+deb9u1) ...
    Setting up patch (2.7.5-1+deb9u2) ...
    Setting up libglib2.0-data (2.50.3-2+deb9u1) ...
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    Setting up udev (232-25+deb9u12) ...
    addgroup: The group `input' already exists as a system group. Exiting.
    update-initramfs: deferring update (trigger activated)
    Setting up libssl1.1:armhf (1.1.0k-1~deb9u1) ...
    Setting up raspberrypi-kernel (1.20190819~stretch-1) ...
    Removing 'diversion of /boot/{........} to /usr/share/rpikernelhack/{....} by rpikernelhack'
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66+ /boot/kernel.img
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66+ /boot/kernel.img
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66-v7+ /boot/kernel7.img
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66-v7+ /boot/kernel7.img
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66-v7l+ /boot/kernel7l.img
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66-v7l+ /boot/kernel7l.img
    Setting up systemd (232-25+deb9u12) ...
    addgroup: The group `systemd-journal' already exists as a system group. Exiting.
    Setting up openssl (1.1.0k-1~deb9u1) ...
    Setting up vim-common (2:8.0.0197-4+deb9u3) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up libpng-dev:armhf (1.6.28-1+deb9u1) ...
    Setting up openssh-client (1:7.4p1-10+deb9u7) ...
    Setting up libdbus-1-3:armhf (1.10.28-0+deb9u1) ...
    Setting up vim-tiny (2:8.0.0197-4+deb9u3) ...
    Setting up libraspberrypi0 (1.20190819~stretch-1) ...
    Setting up libraspberrypi-doc (1.20190819~stretch-1) ...
    Setting up systemd-sysv (232-25+deb9u12) ...
    Setting up libraspberrypi-dev (1.20190819~stretch-1) ...
    Setting up openssh-sftp-server (1:7.4p1-10+deb9u7) ...
    Setting up dbus (1.10.28-0+deb9u1) ...
    A reboot is required to replace the running dbus-daemon.
    Please reboot the system when convenient.
    Setting up libraspberrypi-bin (1.20190819~stretch-1) ...
    Setting up libpam-systemd:armhf (232-25+deb9u12) ...
    Setting up openssh-server (1:7.4p1-10+deb9u7) ...
    Setting up ssh (1:7.4p1-10+deb9u7) ...
    Processing triggers for initramfs-tools (0.130) ...
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    pi@raspberrypi:~ $ reboot
    Failed to set wall message, ignoring: Interactive authentication required.
    Failed to reboot system via logind: Interactive authentication required.
    Failed to open /dev/initctl: Permission denied
    Failed to talk to init daemon.
    pi@raspberrypi:~ $ sudo reboot
    login as: pi
    pi@192.168.13.25's password:
    Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l
    
    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Fri Sep 13 17:47:37 2019 from 192.168.13.23
    pi@raspberrypi:~ $ cu
    curl  cut
    pi@raspberrypi:~ $ cu
    curl  cut
    pi@raspberrypi:~ $ sudo su
    root@raspberrypi:/home/pi# echo "deb https://repo.unipi.technology/debian stretch main" >> /etc/apt/sources.list.d/unipi.list
    root@raspberrypi:/home/pi# wget https://repo.unipi.technology/debian/unipi_pub.gpg -O - | apt-key add
    --2019-09-13 17:56:34--  https://repo.unipi.technology/debian/unipi_pub.gpg
    Resolving repo.unipi.technology (repo.unipi.technology)... 86.49.170.141
    Connecting to repo.unipi.technology (repo.unipi.technology)|86.49.170.141|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1822 (1.8K)
    Saving to: ‘STDOUT’
    
    -                              100%[=================================================>]   1.78K  --.-KB/s    in 0.001s
    
    2019-09-13 17:56:35 (3.25 MB/s) - written to stdout [1822/1822]
    
    OK
    root@raspberrypi:/home/pi# apt-get update
    Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
    Get:3 https://repo.unipi.technology/debian stretch InRelease [17.7 kB]
    Get:4 https://repo.unipi.technology/debian stretch/main armhf Packages [24.1 kB]
    Get:5 https://repo.unipi.technology/debian stretch/main all Packages [7,070 B]
    Fetched 48.9 kB in 1s (31.1 kB/s)
    Reading package lists... Done
    root@raspberrypi:/home/pi# ls
    root@raspberrypi:/home/pi# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@raspberrypi:/home/pi# apt-get install nginx
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
      fontconfig-config fonts-dejavu-core libfontconfig1 libgd3 libjbig0 libnginx-mod-http-auth-pam
      libnginx-mod-http-dav-ext libnginx-mod-http-echo libnginx-mod-http-geoip libnginx-mod-http-image-filter
      libnginx-mod-http-subs-filter libnginx-mod-http-upstream-fair libnginx-mod-http-xslt-filter libnginx-mod-mail
      libnginx-mod-stream libtiff5 libwebp6 libxpm4 libxslt1.1 nginx-common nginx-full
    Suggested packages:
      libgd-tools fcgiwrap nginx-doc ssl-cert
    The following NEW packages will be installed:
      fontconfig-config fonts-dejavu-core libfontconfig1 libgd3 libjbig0 libnginx-mod-http-auth-pam
      libnginx-mod-http-dav-ext libnginx-mod-http-echo libnginx-mod-http-geoip libnginx-mod-http-image-filter
      libnginx-mod-http-subs-filter libnginx-mod-http-upstream-fair libnginx-mod-http-xslt-filter libnginx-mod-mail
      libnginx-mod-stream libtiff5 libwebp6 libxpm4 libxslt1.1 nginx nginx-common nginx-full
    0 upgraded, 22 newly installed, 0 to remove and 0 not upgraded.
    Need to get 3,980 kB of archives.
    After this operation, 8,422 kB of additional disk space will be used.
    Do you want to continue? [Y/n]
    Get:1 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf libjbig0 armhf 2.1-3.1 [27.5 kB]
    Get:2 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf fonts-dejavu-core all 2.37-1 [1,068 kB]
    Get:5 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf libtiff5 armhf 4.0.8-2+deb9u4 [220 kB]
    Get:6 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libwebp6 armhf 0.5.2-1 [202 kB]
    Get:9 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf nginx-common all 1.10.3-1+deb9u3 [105 kB]
    Get:8 http://mirror.de.leaseweb.net/raspbian/raspbian stretch/main armhf libgd3 armhf 2.2.4-2+deb9u5 [114 kB]
    Get:13 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libnginx-mod-http-geoip armhf 1.10.3-1+deb9u3 [86.8 kB]
    Get:14 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian stretch/main armhf libnginx-mod-http-image-filter armhf 1.10.3-1+deb9u3 [89.6 kB]
    Get:3 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf fontconfig-config all 2.11.0-6.7 [271 kB]
    Get:4 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libfontconfig1 armhf 2.11.0-6.7 [313 kB]
    Get:21 http://mirror.netcologne.de/raspbian/raspbian stretch/main armhf nginx-full armhf 1.10.3-1+deb9u3 [390 kB]
    Get:7 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libxpm4 armhf 1:3.5.12-1 [43.6 kB]
    Get:10 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-http-auth-pam armhf 1.10.3-1+deb9u3 [85.7 kB]
    Get:11 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-http-dav-ext armhf 1.10.3-1+deb9u3 [87.4 kB]
    Get:12 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-http-echo armhf 1.10.3-1+deb9u3 [95.4 kB]
    Get:15 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-http-subs-filter armhf 1.10.3-1+deb9u3 [88.8 kB]
    Get:16 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-http-upstream-fair armhf 1.10.3-1+deb9u3 [88.9 kB]
    Get:17 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libxslt1.1 armhf 1.1.29-2.1+deb9u1 [215 kB]
    Get:18 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-http-xslt-filter armhf 1.10.3-1+deb9u3 [88.4 kB]
    Get:19 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-mail armhf 1.10.3-1+deb9u3 [113 kB]
    Get:20 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libnginx-mod-stream armhf 1.10.3-1+deb9u3 [106 kB]
    Get:22 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf nginx all 1.10.3-1+deb9u3 [81.8 kB]
    Fetched 3,980 kB in 12s (316 kB/s)
    


  • second part:

    Preconfiguring packages ...
    Selecting previously unselected package libjbig0:armhf.
    (Reading database ... 34896 files and directories currently installed.)
    Preparing to unpack .../00-libjbig0_2.1-3.1_armhf.deb ...
    Unpacking libjbig0:armhf (2.1-3.1) ...
    Selecting previously unselected package fonts-dejavu-core.
    Preparing to unpack .../01-fonts-dejavu-core_2.37-1_all.deb ...
    Unpacking fonts-dejavu-core (2.37-1) ...
    Selecting previously unselected package fontconfig-config.
    Preparing to unpack .../02-fontconfig-config_2.11.0-6.7_all.deb ...
    Unpacking fontconfig-config (2.11.0-6.7) ...
    Selecting previously unselected package libfontconfig1:armhf.
    Preparing to unpack .../03-libfontconfig1_2.11.0-6.7_armhf.deb ...
    Unpacking libfontconfig1:armhf (2.11.0-6.7) ...
    Selecting previously unselected package libtiff5:armhf.
    Preparing to unpack .../04-libtiff5_4.0.8-2+deb9u4_armhf.deb ...
    Unpacking libtiff5:armhf (4.0.8-2+deb9u4) ...
    Selecting previously unselected package libwebp6:armhf.
    Preparing to unpack .../05-libwebp6_0.5.2-1_armhf.deb ...
    Unpacking libwebp6:armhf (0.5.2-1) ...
    Selecting previously unselected package libxpm4:armhf.
    Preparing to unpack .../06-libxpm4_1%3a3.5.12-1_armhf.deb ...
    Unpacking libxpm4:armhf (1:3.5.12-1) ...
    Selecting previously unselected package libgd3:armhf.
    Preparing to unpack .../07-libgd3_2.2.4-2+deb9u5_armhf.deb ...
    Unpacking libgd3:armhf (2.2.4-2+deb9u5) ...
    Selecting previously unselected package nginx-common.
    Preparing to unpack .../08-nginx-common_1.10.3-1+deb9u3_all.deb ...
    Unpacking nginx-common (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-auth-pam.
    Preparing to unpack .../09-libnginx-mod-http-auth-pam_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-auth-pam (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-dav-ext.
    Preparing to unpack .../10-libnginx-mod-http-dav-ext_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-dav-ext (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-echo.
    Preparing to unpack .../11-libnginx-mod-http-echo_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-echo (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-geoip.
    Preparing to unpack .../12-libnginx-mod-http-geoip_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-geoip (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-image-filter.
    Preparing to unpack .../13-libnginx-mod-http-image-filter_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-image-filter (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-subs-filter.
    Preparing to unpack .../14-libnginx-mod-http-subs-filter_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-subs-filter (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-http-upstream-fair.
    Preparing to unpack .../15-libnginx-mod-http-upstream-fair_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-upstream-fair (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libxslt1.1:armhf.
    Preparing to unpack .../16-libxslt1.1_1.1.29-2.1+deb9u1_armhf.deb ...
    Unpacking libxslt1.1:armhf (1.1.29-2.1+deb9u1) ...
    Selecting previously unselected package libnginx-mod-http-xslt-filter.
    Preparing to unpack .../17-libnginx-mod-http-xslt-filter_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-http-xslt-filter (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-mail.
    Preparing to unpack .../18-libnginx-mod-mail_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-mail (1.10.3-1+deb9u3) ...
    Selecting previously unselected package libnginx-mod-stream.
    Preparing to unpack .../19-libnginx-mod-stream_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking libnginx-mod-stream (1.10.3-1+deb9u3) ...
    Selecting previously unselected package nginx-full.
    Preparing to unpack .../20-nginx-full_1.10.3-1+deb9u3_armhf.deb ...
    Unpacking nginx-full (1.10.3-1+deb9u3) ...
    Selecting previously unselected package nginx.
    Preparing to unpack .../21-nginx_1.10.3-1+deb9u3_all.deb ...
    Unpacking nginx (1.10.3-1+deb9u3) ...
    Setting up libjbig0:armhf (2.1-3.1) ...
    Setting up fonts-dejavu-core (2.37-1) ...
    Setting up nginx-common (1.10.3-1+deb9u3) ...
    Created symlink /etc/systemd/system/multi-user.target.wants/nginx.service → /lib/systemd/system/nginx.service.
    Setting up libnginx-mod-http-subs-filter (1.10.3-1+deb9u3) ...
    Setting up libtiff5:armhf (4.0.8-2+deb9u4) ...
    Processing triggers for sgml-base (1.29) ...
    Setting up libxslt1.1:armhf (1.1.29-2.1+deb9u1) ...
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    Processing triggers for systemd (232-25+deb9u12) ...
    Setting up libnginx-mod-http-auth-pam (1.10.3-1+deb9u3) ...
    Setting up libnginx-mod-http-dav-ext (1.10.3-1+deb9u3) ...
    Setting up libnginx-mod-mail (1.10.3-1+deb9u3) ...
    Setting up libxpm4:armhf (1:3.5.12-1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up libnginx-mod-http-xslt-filter (1.10.3-1+deb9u3) ...
    Setting up libnginx-mod-http-upstream-fair (1.10.3-1+deb9u3) ...
    Setting up libnginx-mod-http-geoip (1.10.3-1+deb9u3) ...
    Setting up libwebp6:armhf (0.5.2-1) ...
    Setting up fontconfig-config (2.11.0-6.7) ...
    Setting up libnginx-mod-stream (1.10.3-1+deb9u3) ...
    Setting up libnginx-mod-http-echo (1.10.3-1+deb9u3) ...
    Setting up libfontconfig1:armhf (2.11.0-6.7) ...
    Setting up libgd3:armhf (2.2.4-2+deb9u5) ...
    Setting up libnginx-mod-http-image-filter (1.10.3-1+deb9u3) ...
    Setting up nginx-full (1.10.3-1+deb9u3) ...
    Setting up nginx (1.10.3-1+deb9u3) ...
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    root@raspberrypi:/home/pi# rm -f /etc/nginx/sites-enabled/default
    root@raspberrypi:/home/pi# apt-get install unipi-modbus-tools
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
      busybox dkms raspberrypi-kernel-headers unipi-common unipi-kernel-modules-dkms
    Suggested packages:
      python3-apport menu
    The following NEW packages will be installed:
      busybox dkms raspberrypi-kernel-headers unipi-common unipi-kernel-modules-dkms unipi-modbus-tools
    0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
    Need to get 17.2 MB of archives.
    After this operation, 110 MB of additional disk space will be used.
    Do you want to continue? [Y/n]
    Get:1 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-kernel-headers armhf 1.20190819~stretch-1 [16.7 MB]
    Get:2 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf dkms all 2.3-2 [74.8 kB]
    Get:3 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf busybox armhf 1:1.22.0-19 [374 kB]
    Get:4 https://repo.unipi.technology/debian stretch/main armhf unipi-common armhf 1.2.8~stretch [16.8 kB]
    Get:5 https://repo.unipi.technology/debian stretch/main armhf unipi-kernel-modules-dkms all 1.30 [51.9 kB]
    Get:6 https://repo.unipi.technology/debian stretch/main armhf unipi-modbus-tools armhf 1.2.8~stretch [28.2 kB]
    Fetched 17.2 MB in 49s (348 kB/s)
    Selecting previously unselected package raspberrypi-kernel-headers.
    (Reading database ... 35178 files and directories currently installed.)
    Preparing to unpack .../raspberrypi-kernel-headers_1.20190819~stretch-1_armhf.deb ...
    Unpacking raspberrypi-kernel-headers (1.20190819~stretch-1) ...
    Selecting previously unselected package dkms.
    Preparing to unpack .../archives/dkms_2.3-2_all.deb ...
    Unpacking dkms (2.3-2) ...
    Selecting previously unselected package busybox.
    Preparing to unpack .../busybox_1%3a1.22.0-19_armhf.deb ...
    Unpacking busybox (1:1.22.0-19) ...
    Selecting previously unselected package unipi-common.
    Preparing to unpack .../unipi-common_1.2.8~stretch_armhf.deb ...
    Adding 'diversion of /boot/overlays/ds2482.dtbo to /usr/share/rpikernelhack/overlays/ds2482.dtbo by rpikernelhack'
    Adding 'diversion of /boot/overlays/neuronee.dtbo to /usr/share/rpikernelhack/overlays/neuronee.dtbo by rpikernelhack'
    Adding 'diversion of /boot/overlays/neuron-spi.dtbo to /usr/share/rpikernelhack/overlays/neuron-spi.dtbo by rpikernelhack'
    Adding 'diversion of /boot/overlays/neuron-spi-new.dtbo to /usr/share/rpikernelhack/overlays/neuron-spi-new.dtbo by rpikernelhack'
    Adding 'diversion of /boot/overlays/unipiee.dtbo to /usr/share/rpikernelhack/overlays/unipiee.dtbo by rpikernelhack'
    Unpacking unipi-common (1.2.8~stretch) ...
    Setting up raspberrypi-kernel-headers (1.20190819~stretch-1) ...
    Selecting previously unselected package unipi-kernel-modules-dkms.
    (Reading database ... 68866 files and directories currently installed.)
    Preparing to unpack .../unipi-kernel-modules-dkms_1.30_all.deb ...
    Unpacking unipi-kernel-modules-dkms (1.30) ...
    Selecting previously unselected package unipi-modbus-tools.
    Preparing to unpack .../unipi-modbus-tools_1.2.8~stretch_armhf.deb ...
    Unpacking unipi-modbus-tools (1.2.8~stretch) ...
    Setting up busybox (1:1.22.0-19) ...
    Setting up dkms (2.3-2) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up unipi-common (1.2.8~stretch) ...
    Removing 'diversion of /boot/overlays/ds2482.dtbo to /usr/share/rpikernelhack/overlays/ds2482.dtbo by rpikernelhack'
    Removing 'diversion of /boot/overlays/neuronee.dtbo to /usr/share/rpikernelhack/overlays/neuronee.dtbo by rpikernelhack'
    Removing 'diversion of /boot/overlays/neuron-spi-new.dtbo to /usr/share/rpikernelhack/overlays/neuron-spi-new.dtbo by rpikernelhack'
    Removing 'diversion of /boot/overlays/neuron-spi.dtbo to /usr/share/rpikernelhack/overlays/neuron-spi.dtbo by rpikernelhack'
    Removing 'diversion of /boot/overlays/unipiee.dtbo to /usr/share/rpikernelhack/overlays/unipiee.dtbo by rpikernelhack'
    Created symlink /etc/systemd/system/sysinit.target.wants/unipicheck.service → /lib/systemd/system/unipicheck.service.
    Created symlink /etc/systemd/system/sysinit.target.wants/unipihostname.service → /lib/systemd/system/unipihostname.service.
    Job for unipicheck.service failed because the control process exited with error code.
    See "systemctl status unipicheck.service" and "journalctl -xe" for details.
    unipicheck.service couldn't start.
    run-parts: executing /etc/kernel/prerm.d/dkms 4.19.66+ /boot/kernel.img
    run-parts: executing /etc/kernel/prerm.d/dkms 4.19.66-v7+ /boot/kernel7.img
    run-parts: executing /etc/kernel/prerm.d/dkms 4.19.66-v7l+ /boot/kernel7l.img
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66+ /boot/kernel.img
    run-parts: executing /etc/kernel/postinst.d/dkms 4.19.66+ /boot/kernel.img
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66+ /boot/kernel.img
    /etc/kernel/postinst.d/initramfs-tools:
    update-initramfs: Generating /boot/initrd.img-4.19.66+
    run-parts: executing /etc/kernel/postinst.d/initrd-config 4.19.66+ /boot/kernel.img
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66-v7+ /boot/kernel7.img
    run-parts: executing /etc/kernel/postinst.d/dkms 4.19.66-v7+ /boot/kernel7.img
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66-v7+ /boot/kernel7.img
    /etc/kernel/postinst.d/initramfs-tools:
    update-initramfs: Generating /boot/initrd.img-4.19.66-v7+
    run-parts: executing /etc/kernel/postinst.d/initrd-config 4.19.66-v7+ /boot/kernel7.img
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.19.66-v7l+ /boot/kernel7l.img
    run-parts: executing /etc/kernel/postinst.d/dkms 4.19.66-v7l+ /boot/kernel7l.img
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.19.66-v7l+ /boot/kernel7l.img
    /etc/kernel/postinst.d/initramfs-tools:
    update-initramfs: Generating /boot/initrd.img-4.19.66-v7l+
    WARNING: missing /lib/modules/4.19.66-v7l+
    Ensure all necessary drivers are built into the linux image!
    depmod: ERROR: could not open directory /lib/modules/4.19.66-v7l+: No such file or directory
    depmod: FATAL: could not search modules: No such file or directory
    depmod: WARNING: could not open /var/tmp/mkinitramfs_AwHrbP/lib/modules/4.19.66-v7l+/modules.order: No such file or directory
    depmod: WARNING: could not open /var/tmp/mkinitramfs_AwHrbP/lib/modules/4.19.66-v7l+/modules.builtin: No such file or directory
    run-parts: executing /etc/kernel/postinst.d/initrd-config 4.19.66-v7l+ /boot/kernel7l.img
    Setting up unipi-kernel-modules-dkms (1.30) ...
    Loading new unipi-1.30 DKMS files...
    dpkg: warning: version 'initrd.inc-initrd.inc' has bad syntax: version number does not start with digit
    dpkg: warning: version '4.19.66+
    4.19.66-v7+' has bad syntax: invalid character in version number
    dpkg: warning: version 'unipi.inc-unipi.inc' has bad syntax: version number does not start with digit
    dpkg: warning: version 'initrd.inc-initrd.inc' has bad syntax: version number does not start with digit
    It is likely that 4.19.66-v7+ belongs to a chroot's host
    Building for 4.19.66+ and 4.19.66-v7+
    Building initial module for 4.19.66+
    Done.
    
    unipi:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.19.66+/extra/
    
    rtc-unipi.ko:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.19.66+/extra/
    
    depmod....
    
    Backing up initrd.img-4.19.66+ to /boot/initrd.img-4.19.66+.old-dkms
    Making new initrd.img-4.19.66+
    (If next boot fails, revert to initrd.img-4.19.66+.old-dkms image)
    update-initramfs...(bad exit status: 1)
    
    -------- Uninstall Beginning --------
    Module:  unipi
    Version: 1.30
    Kernel:  4.19.66+ (armv7l)
    -------------------------------------
    
    Status: Before uninstall, this module version was ACTIVE on this kernel.
    
    unipi.ko:
     - Uninstallation
       - Deleting from: /lib/modules/4.19.66+/extra/
     - Original module
       - No original module was found for this module on this kernel.
       - Use the dkms install command to reinstall any previous module version.
    
    
    rtc-unipi.ko:
     - Uninstallation
       - Deleting from: /lib/modules/4.19.66+/extra/
     - Original module
       - No original module was found for this module on this kernel.
       - Use the dkms install command to reinstall any previous module version.
    
    depmod...
    
    Backing up initrd.img-4.19.66+ to /boot/initrd.img-4.19.66+.old-dkms
    Making new initrd.img-4.19.66+
    (If next boot fails, revert to initrd.img-4.19.66+.old-dkms image)
    update-initramfs...(bad exit status: 1)
    Warning: There was a problem remaking your initrd.  You must manually remake it
    before booting into this kernel.
    
    DKMS: uninstall completed.
    Error! Problems with mkinitrd detected.  Automatically uninstalling this module.
    DKMS: Install Failed (mkinitrd problems).  Module rolled back to built state.
    dpkg: error processing package unipi-kernel-modules-dkms (--configure):
     subprocess installed post-installation script returned error exit status 7
    dpkg: dependency problems prevent configuration of unipi-modbus-tools:
     unipi-modbus-tools depends on unipi-kernel-modules-dkms | unipi-kernel-modules | neuron-kernel (>= 1.13.20180719) | axon-kernel (>= 1.13.20180719); however:
      Package unipi-kernel-modules-dkms is not configured yet.
      Package unipi-kernel-modules is not installed.
      Package neuron-kernel is not installed.
      Package axon-kernel is not installed.
    
    dpkg: error processing package unipi-modbus-tools (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     unipi-kernel-modules-dkms
     unipi-modbus-tools
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@raspberrypi:/home/pi# vi /etc/kernel/post
    postinst.d/ postrm.d/
    root@raspberrypi:/home/pi# vi /etc/kernel/post
    postinst.d/ postrm.d/
    root@raspberrypi:/home/pi# vi /etc/kernel/post
    postinst.d/ postrm.d/
    root@raspberrypi:/home/pi# vi /etc/kernel/postinst.d/
    apt-auto-removal  dkms              initramfs-tools   initrd-config
    root@raspberrypi:/home/pi# vi /etc/kernel/postinst.d/
    apt-auto-removal  dkms              initramfs-tools   initrd-config
    root@raspberrypi:/home/pi# vi /etc/kernel/postinst.d/initrd-config
    root@raspberrypi:/home/pi# history
        1  passwd pi
        2  echo "deb https://repo.unipi.technology/debian stretch main" >> /etc/apt/sources.list.d/unipi.list
        3  wget https://repo.unipi.technology/debian/unipi_pub.gpg -O - | apt-key add
        4  apt-get update
        5  ls
        6  apt-get upgrade
        7  apt-get install nginx
        8  rm -f /etc/nginx/sites-enabled/default
        9  apt-get install unipi-modbus-tools
       10  vi /etc/kernel/postinst.d/initrd-config
       11  history
    root@raspberrypi:/home/pi# apt-get install evok
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
      libavahi-client3 libow-3.1-5 libpython2.7 owfs-common python-ow
    The following NEW packages will be installed:
      evok libavahi-client3 libow-3.1-5 libpython2.7 owfs-common python-ow
    0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 7,258 kB of archives.
    After this operation, 30.3 MB of additional disk space will be used.
    Do you want to continue? [Y/n]
    Get:1 http://mirror1.hs-esslingen.de/pub/Mirrors/archive.raspbian.org/raspbian stretch/main armhf libavahi-client3 armhf 0.6.32-2 [51.3 kB]
    Get:2 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf owfs-common all 3.1p5-1 [16.2 kB]
    Get:3 https://repo.unipi.technology/debian stretch/main armhf evok armhf 2.1.4~stretch [5,979 kB]
    Get:4 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libow-3.1-5 armhf 3.1p5-1 [265 kB]
    Get:5 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf libpython2.7 armhf 2.7.13-2+deb9u3 [914 kB]
    Get:6 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf python-ow armhf 3.1p5-1 [32.2 kB]
    Fetched 7,258 kB in 20s (346 kB/s)
    Selecting previously unselected package libavahi-client3:armhf.
    (Reading database ... 68894 files and directories currently installed.)
    Preparing to unpack .../libavahi-client3_0.6.32-2_armhf.deb ...
    Unpacking libavahi-client3:armhf (0.6.32-2) ...
    Selecting previously unselected package owfs-common.
    Preparing to unpack .../owfs-common_3.1p5-1_all.deb ...
    Unpacking owfs-common (3.1p5-1) ...
    Selecting previously unselected package libow-3.1-5:armhf.
    Preparing to unpack .../libow-3.1-5_3.1p5-1_armhf.deb ...
    Unpacking libow-3.1-5:armhf (3.1p5-1) ...
    Selecting previously unselected package libpython2.7:armhf.
    Preparing to unpack .../libpython2.7_2.7.13-2+deb9u3_armhf.deb ...
    Unpacking libpython2.7:armhf (2.7.13-2+deb9u3) ...
    Selecting previously unselected package python-ow.
    Preparing to unpack .../python-ow_3.1p5-1_armhf.deb ...
    Unpacking python-ow (3.1p5-1) ...
    Setting up libavahi-client3:armhf (0.6.32-2) ...
    Setting up owfs-common (3.1p5-1) ...
    
    Creating config file /etc/owfs.conf with new version
    Setting up libow-3.1-5:armhf (3.1p5-1) ...
    Setting up libpython2.7:armhf (2.7.13-2+deb9u3) ...
    Setting up python-ow (3.1p5-1) ...
    Selecting previously unselected package evok.
    (Reading database ... 68956 files and directories currently installed.)
    Preparing to unpack .../evok_2.1.4~stretch_armhf.deb ...
    Unpacking evok (2.1.4~stretch) ...
    Setting up unipi-kernel-modules-dkms (1.30) ...
    Removing old unipi-1.30 DKMS files...
    
    -------- Uninstall Beginning --------
    Module:  unipi
    Version: 1.30
    Kernel:  4.19.66+ (armv7l)
    -------------------------------------
    
    Status: This module version was INACTIVE for this kernel.
    depmod...
    
    DKMS: uninstall completed.
    
    ------------------------------
    Deleting module version: 1.30
    completely from the DKMS tree.
    ------------------------------
    Done.
    Loading new unipi-1.30 DKMS files...
    dpkg: warning: version 'initrd.inc-initrd.inc' has bad syntax: version number does not start with digit
    dpkg: warning: version '4.19.66+
    4.19.66-v7+' has bad syntax: invalid character in version number
    dpkg: warning: version 'unipi.inc-unipi.inc' has bad syntax: version number does not start with digit
    dpkg: warning: version 'initrd.inc-initrd.inc' has bad syntax: version number does not start with digit
    It is likely that 4.19.66-v7+ belongs to a chroot's host
    Building for 4.19.66+ and 4.19.66-v7+
    Building initial module for 4.19.66+
    Done.
    
    unipi:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.19.66+/extra/
    
    rtc-unipi.ko:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/4.19.66+/extra/
    
    depmod...
    
    Backing up initrd.img-4.19.66+ to /boot/initrd.img-4.19.66+.old-dkms
    Making new initrd.img-4.19.66+
    (If next boot fails, revert to initrd.img-4.19.66+.old-dkms image)
    update-initramfs...(bad exit status: 1)
    
    -------- Uninstall Beginning --------
    Module:  unipi
    Version: 1.30
    Kernel:  4.19.66+ (armv7l)
    -------------------------------------
    
    Status: Before uninstall, this module version was ACTIVE on this kernel.
    
    unipi.ko:
     - Uninstallation
       - Deleting from: /lib/modules/4.19.66+/extra/
     - Original module
       - No original module was found for this module on this kernel.
       - Use the dkms install command to reinstall any previous module version.
    
    
    rtc-unipi.ko:
     - Uninstallation
       - Deleting from: /lib/modules/4.19.66+/extra/
     - Original module
       - No original module was found for this module on this kernel.
       - Use the dkms install command to reinstall any previous module version.
    
    depmod...
    
    Backing up initrd.img-4.19.66+ to /boot/initrd.img-4.19.66+.old-dkms
    Making new initrd.img-4.19.66+
    (If next boot fails, revert to initrd.img-4.19.66+.old-dkms image)
    update-initramfs...(bad exit status: 1)
    Warning: There was a problem remaking your initrd.  You must manually remake it
    before booting into this kernel.
    
    DKMS: uninstall completed.
    Error! Problems with mkinitrd detected.  Automatically uninstalling this module.
    DKMS: Install Failed (mkinitrd problems).  Module rolled back to built state.
    dpkg: error processing package unipi-kernel-modules-dkms (--configure):
     subprocess installed post-installation script returned error exit status 7
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    dpkg: dependency problems prevent configuration of unipi-modbus-tools:
     unipi-modbus-tools depends on unipi-kernel-modules-dkms | unipi-kernel-modules | neuron-kernel (>= 1.13.20180719) | axon-kernel (>= 1.13.20180719); however:
      Package unipi-kernel-modules-dkms is not configured yet.
      Package unipi-kernel-modules is not installed.
      Package neuron-kernel is not installed.
      Package axon-kernel is not installed.
    
    dpkg: error processing package unipi-modbus-tools (--configure):
     dependency problems - leaving unconfigured
    Processing triggers for man-db (2.7.6.1-2) ...
    dpkg: dependency problems prevent configuration of evok:
     evok depends on unipi-modbus-tools; however:
      Package unipi-modbus-tools is not configured yet.
    
    dpkg: error processing package evok (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     unipi-kernel-modules-dkms
     unipi-modbus-tools
     evok
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@raspberrypi:/home/pi# systemctl enable evok
    Created symlink /etc/systemd/system/multi-user.target.wants/evok.service → /lib/systemd/system/evok.service.
    root@raspberrypi:/home/pi# systemctl start evok
    root@raspberrypi:/home/pi# journalctl -xe
    Sep 13 17:59:49 raspberrypi systemd[1]: Failed to start Check Unipi/Neuron/Axon version.
    -- Subject: Unit unipicheck.service has failed
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit unipicheck.service has failed.
    --
    -- The result is failed.
    Sep 13 17:59:49 raspberrypi systemd[1]: unipicheck.service: Unit entered failed state.
    Sep 13 17:59:49 raspberrypi systemd[1]: unipicheck.service: Failed with result 'exit-code'.
    Sep 13 18:11:27 raspberrypi systemd[1]: Starting Cleanup of Temporary Directories...
    -- Subject: Unit systemd-tmpfiles-clean.service has begun start-up
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit systemd-tmpfiles-clean.service has begun starting up.
    Sep 13 18:11:27 raspberrypi systemd[1]: Started Cleanup of Temporary Directories.
    -- Subject: Unit systemd-tmpfiles-clean.service has finished start-up
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit systemd-tmpfiles-clean.service has finished starting up.
    --
    -- The start-up result is done.
    Sep 13 18:17:01 raspberrypi CRON[9649]: pam_unix(cron:session): session opened for user root by (uid=0)
    Sep 13 18:17:01 raspberrypi CRON[9653]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
    Sep 13 18:17:01 raspberrypi CRON[9649]: pam_unix(cron:session): session closed for user root
    Sep 13 18:25:31 raspberrypi systemd[1]: Reloading.
    Sep 13 18:25:31 raspberrypi systemd[1]: apt-daily.timer: Adding 3h 31min 14.563985s random time.
    Sep 13 18:25:31 raspberrypi systemd[1]: apt-daily-upgrade.timer: Adding 29min 30.130751s random time.
    Sep 13 18:25:37 raspberrypi systemd[1]: Starting EVOK ModBus/WebSocket/RPC Server...
    -- Subject: Unit evok.service has begun start-up
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit evok.service has begun starting up.
    Sep 13 18:25:37 raspberrypi systemd[1]: Started EVOK ModBus/WebSocket/RPC Server.
    -- Subject: Unit evok.service has finished start-up
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit evok.service has finished starting up.
    --
    -- The start-up result is done.
    root@raspberrypi:/home/pi# reboot
    login as: pi
    pi@192.168.13.25's password:
    Linux L203-sn226 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l
    
    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Fri Sep 13 17:56:05 2019 from 192.168.13.23
    pi@L203-sn226:~ $ sudo su
    root@L203-sn226:/home/pi# systemctl start evok
    root@L203-sn226:/home/pi# systemctl status evok
    ● evok.service - EVOK ModBus/WebSocket/RPC Server
       Loaded: loaded (/lib/systemd/system/evok.service; enabled; vendor preset: enabled)
       Active: active (running) since Fri 2019-09-13 18:26:16 BST; 57s ago
      Process: 583 ExecStartPre=/bin/ln -sf /etc/nginx/sites-enabled/evok /etc/evok-nginx.conf (code=exited, status=0/SUCCESS
      Process: 576 ExecStartPre=/bin/rm -f /etc/nginx/sites-enabled/mervis (code=exited, status=0/SUCCESS)
      Process: 570 ExecStartPre=/bin/mv -f /etc/nginx/sites-enabled/mervis /etc/nginx/sites-available/ (code=exited, status=1
      Process: 564 ExecStartPre=/bin/cp -f /etc/nginx/sites-available/evok /etc/nginx/sites-enabled/ (code=exited, status=1/F
     Main PID: 588 (python)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/evok.service
               └─588 /opt/evok/bin/python /opt/evok/lib/python2.7/site-packages/evok/evok.py
    
    Sep 13 18:26:16 L203-sn226 systemd[1]: Starting EVOK ModBus/WebSocket/RPC Server...
    Sep 13 18:26:16 L203-sn226 systemd[1]: Started EVOK ModBus/WebSocket/RPC Server.
    ...skipping...
    ● evok.service - EVOK ModBus/WebSocket/RPC Server
       Loaded: loaded (/lib/systemd/system/evok.service; enabled; vendor preset: enabled)
       Active: active (running) since Fri 2019-09-13 18:26:16 BST; 57s ago
      Process: 583 ExecStartPre=/bin/ln -sf /etc/nginx/sites-enabled/evok /etc/evok-nginx.conf (code=exited, status=0/SUCCESS
      Process: 576 ExecStartPre=/bin/rm -f /etc/nginx/sites-enabled/mervis (code=exited, status=0/SUCCESS)
      Process: 570 ExecStartPre=/bin/mv -f /etc/nginx/sites-enabled/mervis /etc/nginx/sites-available/ (code=exited, status=1
      Process: 564 ExecStartPre=/bin/cp -f /etc/nginx/sites-available/evok /etc/nginx/sites-enabled/ (code=exited, status=1/F
     Main PID: 588 (python)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/evok.service
               └─588 /opt/evok/bin/python /opt/evok/lib/python2.7/site-packages/evok/evok.py
    
    Sep 13 18:26:16 L203-sn226 systemd[1]: Starting EVOK ModBus/WebSocket/RPC Server...
    Sep 13 18:26:16 L203-sn226 systemd[1]: Started EVOK ModBus/WebSocket/RPC Server.
    ~
    ~
    ~
    ~
    ~
    ~
    root@L203-sn226:/home/pi# netstat -tuplen
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode      PID/Program name   
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          14927      754/sshd           
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      0          12791      588/python         
    tcp6       0      0 :::22                   :::*                    LISTEN      0          14929      754/sshd           
    tcp6       0      0 :::8080                 :::*                    LISTEN      0          12792      588/python         
    udp        0      0 0.0.0.0:68              0.0.0.0:*                           0          13502      739/dhcpcd         
    udp        0      0 0.0.0.0:5353            0.0.0.0:*                           108        10691      565/avahi-daemon: r
    udp        0      0 0.0.0.0:53241           0.0.0.0:*                           108        10693      565/avahi-daemon: r
    udp6       0      0 :::546                  :::*                                0          13520      739/dhcpcd         
    udp6       0      0 :::5353                 :::*                                108        10692      565/avahi-daemon: r
    udp6       0      0 :::49513                :::*                                108        10694      565/avahi-daemon: r
    root@L203-sn226:/home/pi# ls /etc/nginx/sites-enabled/
    root@L203-sn226:/home/pi# systemctl status evok
    ● evok.service - EVOK ModBus/WebSocket/RPC Server
       Loaded: loaded (/lib/systemd/system/evok.service; enabled; vendor preset: enabled)
       Active: active (running) since Fri 2019-09-13 18:26:16 BST; 2min 25s ago
      Process: 583 ExecStartPre=/bin/ln -sf /etc/nginx/sites-enabled/evok /etc/evok-nginx.conf (code=exited, status=0/SUCCESS
      Process: 576 ExecStartPre=/bin/rm -f /etc/nginx/sites-enabled/mervis (code=exited, status=0/SUCCESS)
      Process: 570 ExecStartPre=/bin/mv -f /etc/nginx/sites-enabled/mervis /etc/nginx/sites-available/ (code=exited, status=1
      Process: 564 ExecStartPre=/bin/cp -f /etc/nginx/sites-available/evok /etc/nginx/sites-enabled/ (code=exited, status=1/F
     Main PID: 588 (python)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/evok.service
               └─588 /opt/evok/bin/python /opt/evok/lib/python2.7/site-packages/evok/evok.py
    
    Sep 13 18:26:16 L203-sn226 systemd[1]: Starting EVOK ModBus/WebSocket/RPC Server...
    Sep 13 18:26:16 L203-sn226 systemd[1]: Started EVOK ModBus/WebSocket/RPC Server.
    root@L203-sn226:/home/pi# ls /etc/nginx/sites-available/
    default  evok.dpkg-new
    root@L203-sn226:/home/pi# ls -la /etc/nginx/sites-enabled/
    total 8
    drwxr-xr-x 2 root root 4096 Sep 13 17:58 .
    drwxr-xr-x 8 root root 4096 Sep 13 17:57 ..
    root@L203-sn226:/home/pi# cat /etc/evok-nginx.conf
    cat: /etc/evok-nginx.conf: No such file or directory
    
    


  • Same happened to me yesterday, running apt update & apt upgrade on fresh UniPian-Neuron-2019-01-07-v1.9 results in broken system.

    I'm sure that I did just the same steps a couple of weeks ago without any problems.


  • administrators

    We have found the issue. In the meantime, you can fix it by running the apt upgrade command three times each followed with a reboot.


  • administrators

    Should be fixed in the recent update.


  • administrators

    You can try to install unipi-kernel-modules package containing precompiled modules (while the unipi-kernel-modules-dkms package is removed automatically).

    sudo su
    apt-get update
    apt-get install unipi-kernel-modules
    

    Current version of the package is 1.32.1.xxxx