xG1W-2 1 Wire Gateway reset on power cut



  • Hi,
    I have the xG1W-2 One Wire gateway very successful in use. The configuration with the Software via USB connection is quite easy and works.
    The problem is that the gateway seems not to read the values from connected sensors after a power cut. It could be that the gateway has lost its configuration. Currently it returns only -280 values to the Neuron.
    This behaviour is not very usefull for remote installation without direct access.
    How can I configure the gateway to store its configuration permanently?

    Regards
    Maayen



  • To continue this.
    I had the possibility to load the configuration again on the gateway and I also switched the programming DIP switch. Next problem is that the Neuron does not receive any data at all.

    How should I configure the gateway? Any possbility to fix that without physical access?

    @Martin-Kudláček @tomas_hora any suggestions


  • administrators

    @kalophain if 1wire sensor is loaded to the channel, it's ID is stored in the non-volatile memory and so it should be restored upon boot of the gateway. Since the memory is tested on every piece, the probability that it no ok is really low.

    The DIP switch is used for firmware change and has no affect to the store/load of the sensors.

    Please make sure that:

    • the baudreate in Neuron and GW is the same 0_1569339863243_GW_pic2.png

    • check that the addresses stored in the GW and loaded from the neuron are the same 0_1569339910879_GW_pic.png

    • upload the latest FW 1.24 to the GW

    • loadand save the sensor to the channel multiple times


Log in to reply