evok start error



  • Hi

    Fresh installed image image from 09.2017 raspian-stretch lite :

    root@raspberrypi:/home/pi# cat /etc/debian_version
    9.1
    

    Kernel :

    root@raspberrypi:/home/pi# uname -a
    Linux raspberrypi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux
    

    no apt upgrade only apt update

    after install evok from git and final reboot evok not starting .

    root@raspberrypi:/home/pi# service evok status
    ● evok.service - Evok Modbus/Websocket/Rpc Server
       Loaded: loaded (/etc/systemd/system/evok.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2018-05-24 19:01:39 UTC; 56s ago
      Process: 503 ExecStart=/usr/bin/python /opt/evok/evok.py (code=exited, status=1/FAILURE)
     Main PID: 503 (code=exited, status=1/FAILURE)
    
    May 24 19:01:39 raspberrypi systemd[1]: evok.service: Service hold-off time over, scheduling restart.
    May 24 19:01:39 raspberrypi systemd[1]: Stopped Evok Modbus/Websocket/Rpc Server.
    May 24 19:01:39 raspberrypi systemd[1]: evok.service: Start request repeated too quickly.
    May 24 19:01:39 raspberrypi systemd[1]: Failed to start Evok Modbus/Websocket/Rpc Server.
    May 24 19:01:39 raspberrypi systemd[1]: evok.service: Unit entered failed state.
    May 24 19:01:39 raspberrypi systemd[1]: evok.service: Failed with result 'exit-code'.
    

    and

    oot@raspberrypi:/home/pi# /usr/bin/python /opt/evok/evok.py
    Traceback (most recent call last):
      File "/opt/evok/evok.py", line 1239, in <module>
        class VersionHandler(UserCookieHelper, APIHandler):
      File "/opt/evok/evok.py", line 1240, in VersionHandler
        self.version = 'Unspecified'
    NameError: name 'self' is not defined
    

    any tips hints ?

    Regards



  • Hi
    after copy from the old evok version before :

    sudo cp -r tornadorpc_evok /usr/local/lib/python2.7/dist-packages
    sudo cp -r opt/* /opt/
    sudo cp -r evok/ /opt/
    

    unipi start and modbus running to extension

    Regards un|x



  • forget to post the system defaults
    raspian-lite April 2018

    root@pimatic:~# cat /etc/debian_version 
    9.4
    root@pimatic:~# uname -a
    Linux pimatic 4.14.43-v7+ #1115 SMP Fri May 25 14:27:48 BST 2018 armv7l GNU/Linux
    

    Regards un|x



  • @unix

    Hi unix,

    I installed a few Unipi 1.1 and UniPi Lite 1.1's. A few days ago I want to install a new one (raspbian + evok), And I have the same problem. I tried to remove and re-install the Evok, it did not help. I re-installed everything (OS + evok), same result. You are not the only one with this problem.
    I hope there is solution soon....

    https://forum.unipi.technology/topic/669/same-evok-start-error


  • administrators

    @unix, @Bart-Delaere

    Reposting from the other thread, the Master branch is currently buggy:

    It looks like the latest master commit on EVOK has a bug in that regard. We've recently added functionality to query the version of EVOK via the API, but it looks like it might be buggy.
    
    I recommend downloading a stable release by following the instructions on the [GitHub page](https://github.com/UniPiTechnology/evok) instead. I will fix the issue on the master branch today.
    

    It should be fixed today within a few hours.


  • administrators

    @unix
    The issue should now be fixed both in Master and in the latest release. v.2.0.5f

    As a side note you can now query the version of your EVOK via /version/, though unfortunately it only applies from v.2.0.5f onwards.