Variables are not mounted to HMI gadgets

  • I am forwarding traffic for specific port to my Unipi. I have a set of variables which I need to control from HMI. But I can see only ? ? ? . Where is an issue?

  • administrators

    @Martin-Trojan make sure that the ports required for the HMI are also available, eg: 9999

  • I cant see any port(settings) for HMI. Where can I found it? How HMI communicate with Mervis solution on Unipi?

    HMI sending request to api.cgi



    {"ver":1,"code":"error","msg":"No variables from request available. Check device parameters and availability."}

    I allowed port 9999 to forward to my Unipi device.

    Any suggestion?

  • administrators

    @Martin-Trojan The port for HMI communication between the fastcgi server and the web is hardcoded and cannot be changed easily from the IDE/HMI.

    Has it worked for you on a local network without any port forward?

  • It has worked, but I continuous with development. Then my provider gave me IP, I deployed new version to UNIPI, Uploaded new HMI, set static IP in my local network for Unipi and forwarded port for web to unipi:80 and 12346 forwarded to unipi:12346. Then I also forwarded 9999 as you have suggested. When I debug I can see values. When open web browser with HMI webpage I can see only ? ? ? Can you see any issue? What is Networking settings for in Mervis? Which IP should be there?

  • What I am missing is information how Mervis program on Unipi and HMIweb on Unipi communicate each other? Then I can try to resolve where is an issue.

  • administrators

    Sharkrt and Fastcgi are running locally on UniPi. I think you should only need the port 80. Please try to make a clean HMI with just one variable and upload that...

    Sometimes it happens that the mapping of variables in HMI breaks...

  • This post is deleted!

Log in to reply

Looks like your connection to Forum was lost, please wait while we try to reconnect.