Oživení starého projektu - chybí DS2408_sh_trans



  • Dobrý den,
    prosím o pomoc, mám běžící UniPi 1.1 na kterém je fungující projekt který jsem vytvořil s Mervis-em nějaké starší verze, poslední upgrade mohl být někdy kolem roku 2017.

    Nyní bych projekt rád rozšířil. Mám jeho zdrojové soubory ale nemám image pro RPi ani staré instalace Mervis-u.

    V projektu mám použité vstupní a výstupní desky které dnes již nemáte v nabídce. Ty komunikují přes 1wire a bez nich se bohužel neobejdu.

    Už jsem resignoval na to že použiju původní zdrojový projekt, ale nedaří se mi zprovoznit ani kombinaci hw zařízení.

    Jakou verzi Mervis mi prosím doporučíte pokud chci i nadále provozovat UniPi1.1 se starým RaspberryPI 2 a s 1wire zařízeními (viz. níže)?

    Pokud zkusím Mervis IDE 2.1.3 (pro starší nenabízíte os image), tak narážím na nefunkčnost zařízení z knihovny (UniPi / OneWire / 1W-4R-4DI a UniPi / OneWire / 1W-8R ) protože v Mervis-s chybí transformace DS2408_sh_trans.
    Pro toto jsem kdysi od Vás dostal knihovnu "Lib.UniPi_basic.slb" která ale zřejmě už není kompatibilní s verzí 2.1.3 a tak ani s ní projekt nejde přeložit.
    Je možné získat tuto knihovnu pro Mervis 2.1.3 ?

    Pokud zkusím Mervis IDE 2.2.0 a image Unipi-1.1_Mervis-OS_image_v2.2.0.30.zip, tak narazím na to že je vyžadována licence (o které píšete, že až od 2.3.0). Na licenci nemám ani žádanku, neboť UniPi a Mervis jsem koupil na konci roku 2015. Je možné licenci dodatečně získat?

    (Kdyžtak výše uvedená zařízení, tak jak jsou v knihovně, nefungují ani v 2.2.0 ale asi stačí transformaci přehodit na vestavěnou lib.Unipi.ds2408_sh_trans)

    Děkuji za nasměrování co dál


  • administrators

    Dobrý den,

    licence je skutečně vyžadována až od verze IDE 2.3.0. Ve verzi IDE 2.2.0 se sice zobrazí stav "Nezalicencováno", ale jedná se jen o přípravu.

    Doporučuji přejít na nejnovější verzi IDE 2.4.1, která má lépe řešenu práci s úložištěm a nedochází tak při správném nastavení k upisování SD karet, nebo eMMC úložiště (u vyšších řad PLC).

    Licenci Mervis je možné zakoupit na našem e-shopu.

    Transformaci DS2408_sh_trans nahraďte za lib.Unipi.ds2408_sh_trans. Jsou totožné.

    Přeji hezký den,
    Antonín


Log in to reply