Broken dependencies during EVOK installation



  • Hello.

    There is a problem during installation of EVOK API.
    Running command apt-get install evok returns error:

    unipi-kernel-modules : Depends: axon-kernel-image (= 1:1.20210527-1) but it is not installable or
    raspberrypi-kernel (= 1:1.20210527-1) but 1.20210303-1 is to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

    I've tried running apt update && apt upgrade as described here https://forum.unipi.technology/topic/744/can-not-install-evok-due-to-dependencies/8, but it returns the same error. OS reboot doesn't help either.

    Device - Neuron S103
    OS image - neuron-opensource-os_image-20210426.0.zip (shouldn't evok be preinstalled on opensource image?).

    Looking forward to your reply.

    Vladislav


  • administrators

    Hello @khachvla,
    I just used the said image and the Neuron S103 and the Evok installed properly. There is something inconsistent, because apt-get install evok should not return the said message. The unipi-kernel-modules packages are already there.

    The Evok is not preinstalled on the opensource image. This image only contains the basic images for interacting with the underlying HW, mainly the unipi-kernel-modules.

    Can you please flash the SD card with the clean opensource OS image and do apt update && apt install -y evok. Please, post the complete result, to see what's going on.

    Thank you and have a nice day,
    Martin



  • @Martin-Kudláček After flashing the image everything works fine. Thank you


Log in to reply