Wifi problem on Axon M565 LTE



  • Hello everybody,

    I have a stability problem with the internal Wifi adapter of an Axon M565 LTE. I am using original Raspbian image from your download section, updated to the latest version.

    Wifi works correctly for some time, going from some hours to some days then disconnect. Once disconnected, I am unable to get it back to work except with a cold reboot.

    I put a temporary network cable to check logs and dmesg, here is what I noticed:

    [32819.275600] brcmfmac: brcmf_do_escan: error (-110)
    [32819.275650] brcmfmac: brcmf_cfg80211_scan: scan error (-110)
    [32819.787535] brcmfmac: brcmf_fil_cmd_data: bus is down. we have nothing to do.

    I tried to rmmod/modprobe the brcmfmac module, but I only get some more errors in return:

    [32870.984472] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
    [32870.984529] brcmfmac: brcmf_c_preinit_dcmds: Retreiving cur_etheraddr failed, -110
    [32870.984558] brcmfmac: brcmf_bus_started: failed: -110
    [32870.984601] brcmfmac: brcmf_sdio_firmware_callback: dongle is not responding

    Am I the only one to have that problem ? Some searches on the web return me a lot of people having that problem but not on Axon controllers. Mainly on RPi 3. Is the Wifi adapter similar in the RPi3 and in the Axon ?

    Any help would be highly appreciated.

    Regards.

    Olivier.


  • administrators

    Hello @oflock,

    thank you for using our products!

    As the internal single-board computer has an onboard WiFi adapter with no external antenna outside the unit and the unit has a metal enclosure, the WiFi performance is probably affected by this. The other factor is some of the LTE bands used can interfere with the WiFi frequencies.

    The WiFi adapter in the Axon PLC series is designed mainly for occasional service access and/or initial setup.


Log in to reply