1 wire with node-red os image



  • Hello,

    I'm using a unipi neuron m203 and want to connect several 1-wire sensors (ds18b20 and ds28e17) and program this using node-red. But there is a problem when I use the newest node-red os image (neuron-node-red_image-20200610.8).

    In a previous version of this os image (neuron-node-red_image-20200507.2) there was no problem at all. In the image below the adresses of the connected device can be found in the /sys/bus/w1/devices map. And i'm able to communicate with these devices through node-red.
    7e362fe2-60c7-4e59-b9f0-51ac7b4d506b-image.png

    But if I use the newest node-red os image, the devices won't show up. After some research I found that it maybe has to do something with the driver of the internal ds2482 chip (1-wire master). When I do i2cdetect with the old version of the node-red image (neuron-node-red_image-20200507.2), it outputs a UU at the adress of the ds2482. This can be seen in the image.
    fc539d5d-852d-4658-8519-7ed29d8e7ac4-image.png
    But when I run this command with the newest node-red os image (neuron-node-red_image-20200610.8), it outputs the adress 18 at the adress of the ds2482. After some research, I found that UU means that a driver uses this adress. This means that I think that the driver of the ds2482 is not set up propperly in the newest node-red image because it outputs the adress 18, which means that there is a device at this adress (and it is not in use by a driver). So I tried to start the ds2482 driver in the newest node-red os image, but I didn't seem to work. Am I thinking correctly here or am I overseeing something? I hope someone can help me with this problem.

    I'm sorry for my bad English and thanks in advance.

    Best Regards.


  • administrators

    Hello,

    yes - several versions back, there was a change in Evok package (underlying layer for communication with I/Os) regarding 1-Wire access method. The kernel driver for the 1-Wire master is removed as Evok uses another method (OWFS) instead.

    Basically, you have two options possible:

    1. Use Evok - follow THIS tutorial
    2. Disable 1W bus in Evok (comment it out in the /etc/evok.conf) and enable DS2482 kernel module loading by enabling the ds2482 device-tree overlay in /boot/config.txt. In this case, you, of course, cannot use access to a sensor through the Unipi node anymore.


  • Hello Martin,

    Thanks for the reaction!
    Okey, I indeed thought it had something to do with that, but I couldn't find any update notes on the os image.
    I don't really need to access the sensors through the unipi node anyways, so I'm going to try option 2.

    Best Regards


Log in to reply