Little update: We had still some work to do on our heatingplant, we had some flow issues to fix to let the boiler do a good job. After we did this, we noticed that the boiler keeps burning on low flame. Even if the setpoint was high, the boiler stays at low flame. We found out that we need to write a value at this register as well: 14 maximum relative modulation level setting By default all values are 0, even this one. When you give customers some advice about controlling their boiler with unipi, you should tell them this: ;) When a boiler needs to be controlled at setpoint: write modulating supply setpoint at register 1 write fixed setpoint of maximum load of the boiler on register 14 (100%) When a boiler needs to be controlled at cappacity: write fixed supply setpoint at register 1 (90°) Write modulating value of requested load setpoint on register 14