HMI Cannot add more variables



  • Hello,

    When I try to add variables into an HMI setter, I get the error:

    Error PLC PLC
    WebControl 1 2 Unable to write variable link '', check if the property 'Variable' is set properly and build the project again.

    I have added lots of other variables, but one of them in particular, although it shows in the program, does not show up in the HMI to be used.

    If I try to add new variables, they do not show up in the HMI to be used.

    HELP!!



  • Here's a screen shot from the variables browser. I am not sure why new variables, or this one specifically went wrong after I added a new one - appears crossed out "PLC Value" in the variable browser. Have I reached some maximum in the number that can be defined?

    0_1551017087739_84bad994-d14c-489b-910c-591745191a55-image.png



  • Ok - I've lost another one that was working before. I have changed the logic in the main program to do something slightly different with the global variable. But now it has also gone from the HMI.

    Error PLC PLC
    WebControl 6 3 Unable to write variable link 'HMI_3_06', check if the property 'Variable' is set properly and build the project again.

    0_1551020968605_da58fecd-6a18-4d56-b38a-0b896e416b90-image.png

    Any advice what to do? I don't understand what is going wrong. Start new project again from scratch? :-(


  • administrators

    Hello @robl,
    it is hard to say without looking at the project. The reason could be, that the variable is not used anywhere in the program. The Mervis then ignores the variable and the variable is not available in the HMI (hence the "Unable to write variable link"). You can avoid this behaviour by wiring the variable to itself:

    0_1551083790936_a3532456-8b6d-4a81-819f-7c6d26b17c48-image.png

    If that doesn't help, please send the project to support@unipi.technology and I'll take a look at it.

    Best regards,
    Martin



  • Yes, it's very odd.

    In the end, I reverted to an older version of the project and just re-did the all the missing parts, since I had 3 days in Austria to deploy it all and needed to fix it before returning to the UK. I can remotely access it via the proxy for the time being though to do updates.

    I thought it would be a good idea to put everything in my google drive folder, so that when changes happen, it's automatically backed up somewhere. Mervis IDE does not seem to like this though. During the build when you have HMI parts, it pops up some errors:

    0_1551438757561_c04b55df-0526-4c2a-bff6-f1df303e8a8a-image.png

    0_1551438777888_3b30ba69-c561-408f-a78f-a5ef9d5ac3b9-image.png

    0_1551438820608_a2249e8c-fe8c-4cce-bc64-478d380996e9-image.png

    I just click "Abort" on each of these errors every time it builds, and it seems to build anyway.

    It was working fine with Google Drive before I started to create HMI Projects (e.g. only function blocks) I think it basically tries to delete some files after it builds and something goes wrong as the files are still being worked on by Google Drive syncing, or these files only exist for a short time and it just takes Google Drive a while to catch up with syncing and then deleting them.) Sometimes I get errors about another process having a file open, but usually running the build again or restarting the IDE, it works. Doesn't seem to cause any noticeable problems, but perhaps if that part of the project did not change, it won't cause a problem if it fails to update that particular file.

    Then I thought I should save the file as... to a new location on a local directory instead of Google Drive and open this. This gets rid of the errors during build, but the variable problems started to occur as above. Adding new ones doesn't work, even when they are correctly linked to a function block, and worked before. Only thing I have done was replace one function block with different, similar function block, and link it back in as before.

    I tried all sorts of things to get it working again, making new variables... clearing the flash variables.. nothing seemed to fix it.

    So I had to abandon that project and go back to the one on google drive.

    I notice it has this error appearing about a missing part in the file, though I have not noticed anything is broken. I'm not sure how the path got to have "Google Drive\google drive" in there, since this is obviously wrong. (Its somehow in there twice.)

    0_1551439069121_e844c328-8705-4ef3-95b1-7f0cdcff4100-image.png


  • administrators

    Hello @robl,
    we also do have a problem with storing the Mervis project files into folder controlled by a cloud service. We use One Drive and it also causes some problems. We account this to the fact, that not all files are stored locally, and the OneDrive downloads them on demand. The OneDrive has a function to override this (sorry for the Czech language):

    0_1551447694257_c393e6af-404c-49b8-b8ca-8673f52f103c-image.png

    The function is called "Always keep on this device".

    So all in all, your project files are in unknown state. Maybe we would be able to fix the missing SPR file, but we cannot guarantee that it will fix the project completely. The safest way is to recreate the project from the beginning.

    I would also suggest you to take a look at some source code management tool (like [git](https://git-scm.com/ for instance) for storing versions of the project so you would be able to revert to previous state.



  • Hi,

    Again I start to have this problem where new variables just are not picked up, and they are correctly linked in. They are again not available in the HMI. The PLC value is just "no value" after build and deploy, and I can't get it to set an initial value whatever I try.

    I don't get the error about variable 'Variable' unlike last time however.

    Any help on how I can get it working. Re-creating entire programs just to get this working again remotely is very time consuming and risky.

    0_1559908069439_cc88ed3c-d553-4365-bb4d-4fb5f261e6e4-image.png

    Result is: make one small change and large amounts of the program stop working correctly because they are not getting the values needed for the functions to work.

    Any thoughts? Or just abandon it all and see if something else is less fragile? Node Red?? Not something I can do remotely right now but worth looking in to?



  • 0_1559909211138_034debcb-00d8-4f0f-bf32-e2f79989f461-image.png

    Problem seems to be triggered when replacing an existing function with a similar function, then any new vars stop working, any changed vars stop working, and the function stops returning any output even though it's getting everything valid input.