Webhook



  • Hi,
    I can not establish sending notifications via webhook. Evok sends notification, but without any values. This is what I recieve:

    0000   50 4f 53 54 20 2f 20 48 54 54 50 2f 31 2e 31 0d   POST / HTTP/1.1.
    0010   0a 43 6f 6e 74 65 6e 74 2d 54 79 70 65 3a 20 61   .Content-Type: a
    0020   70 70 6c 69 63 61 74 69 6f 6e 2f 78 2d 77 77 77   pplication/x-www
    0030   2d 66 6f 72 6d 2d 75 72 6c 65 6e 63 6f 64 65 64   -form-urlencoded
    0040   0d 0a 43 6f 6e 6e 65 63 74 69 6f 6e 3a 20 63 6c   ..Connection: cl
    0050   6f 73 65 0d 0a 43 6f 6e 74 65 6e 74 2d 4c 65 6e   ose..Content-Len
    0060   67 74 68 3a 20 39 31 0d 0a 48 6f 73 74 3a 20 31   gth: 91..Host: 1
    0070   39 32 2e 31 36 38 2e 31 2e 31 39 34 3a 38 30 0d   92.168.1.194:80.
    0080   0a 41 63 63 65 70 74 2d 45 6e 63 6f 64 69 6e 67   .Accept-Encoding
    0090   3a 20 67 7a 69 70 0d 0a 0d 0a 5b 22 67 6c 6f 62   : gzip....["glob
    00a0   5f 64 65 76 5f 69 64 22 2c 20 22 75 6e 69 74 22   _dev_id", "unit"
    00b0   2c 20 22 76 61 6c 75 65 22 2c 20 22 63 69 72 63   , "value", "circ
    00c0   75 69 74 22 2c 20 22 72 61 6e 67 65 5f 6d 6f 64   uit", "range_mod
    00d0   65 73 22 2c 20 22 6d 6f 64 65 73 22 2c 20 22 72   es", "modes", "r
    00e0   61 6e 67 65 22 2c 20 22 64 65 76 22 2c 20 22 6d   ange", "dev", "m
    00f0   6f 64 65 22 5d                                    ode"]
    

    Thank you for your help.


  • administrators

    @budulinek
    Which version of EVOK are you using? I believe this is an issue which came up before and should be fixed now, though it's possible it occurred again because of some other recent changes

    Should be fixed in release 2.0.6a. You will need to use either the latest release (2.0.6a) or the latest development Master ( e9b7166) to obtain the fix