Help about UNIPI v1.1 on codesys

  • Hi,

    before talk about my problem, I would says talk I've read all documentation from UNIPI and from CODESYS. I've passed more than 30hours before make just I was not missing something.

    I've bought UNIPI v1.1 earlier and using it on my Raspberry pi 3. I've installed Codesys and the plug-in.
    My raspbian is up to date.

    I ran the script given from codesys package to install the UNIPI on raspbian.

    2 things are not working. First the digital input doesnt work. When I connect +12v to any input. The led turn on but no state change into Codesys. Codesys is telling me that the BUS is not currently running. very strange.

    The relay over I2c are working properly so I figure that the I2c port is OK.

    Other thing that is not working is the DS18B20. I was having 1-wire sensor on my arduino. I took them and using my breadboard and a lan cable connected it using the correct pin-out provided by you. I'm 100% sure that the DS18B20 are working and can use my arduino for the address but I'm not supposed to work that way. So I tried many things but not succesfully. I can't figure why unipi doesn't give a Test Project sample that is 100% working on codesys to check what is wrong.

    At the moment, my program is running, Onewire_master is running but not DS18B20 because of ''No driver found''![alt text]0_1489266970935_no driver.jpg

  • Finally another user with the same problems ..... unfortunately !!
    They're in your same conditions with the DS18B20 and so with I2C emo-R8 ..... nothing works !!
    I contacted him the UNIPI software developer for CoDeSys it and in the end I should 'I' € 350 for code development for the management of EMO-R8 even I were unipi tecknology !!.
    For the speech of the DS18B20 put down the cravings, I think you address anything in CoDeSys !!
    If you try Mervis, that I do not like at all, you'll see that everything works also DS18B20 !!
    The fact is that the unipi software CoDeSys was created ( without any compensation from unipi so I think you will have to change course.
    At the moment I'm looking at monitor of Arduino Controllino which also shows a much better container of unipi, is programmed with Visuino.
    What is holding me back is that unlike CoDeSys Visuino not generate the web part to control.

    Codesys I find it a bit slow in programming but fantastic from all points of view but, unfortunately, not compatible with unipi

    Good luck, Alberto

  • Problem fixed after clean install of most recent raspbian version

  • @Alverman Development for supporting the EMO-R8 is now underway and will be available later this year

Log in to reply