debug log file size



  • Hi,

    I'm getting a lot of log entries in /var/log/debug and /var/log/daemon.log files. They are getting huge, and not rolling over to make it easy to delete the older files. Can I reduce the level of logging from evok?

    Thanks.
    Merv.


  • administrators

    @Merv Could you share an example of the entries of both logs?

    The logging level can be changed in /etc/systemd in evok.service file available options described online.



  • The log entries look as follows:
    Feb 13 08:19:23 VacuumPLC evok[425]: [I 170213 08:19:23 web:1971] 200 GET /rest/relay/2_01/ (::1) 1.81ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/ai/1_01 (::1) 1.81ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_01/ (::1) 1.92ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_02/ (::1) 1.76ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_03/ (::1) 1.81ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_04/ (::1) 1.90ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_05/ (::1) 1.80ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_06/ (::1) 1.81ms
    Feb 13 08:19:24 VacuumPLC evok[425]: [I 170213 08:19:24 web:1971] 200 GET /rest/relay/2_02/ (::1) 1.93ms
    Feb 13 08:19:25 VacuumPLC evok[425]: [I 170213 08:19:25 web:1971] 200 GET /rest/ai/1_01 (::1) 1.79ms

    The cause of them is my python program that is monitoring the status of a vacuum sensor, and checking what pumps are on and off, and switching pumps on and off. but, while I want to keep checking the status of the relays, I dont need to be creating so much debug activity. I'll take a look at the links you sent me.
    Merv.



  • I've tried setting the SysLogLevel parameter to a few different values, it's currently set to "emerg" which should report almost nothing.

    The lines (as above) are now being written to daemon.log (as before) but now also into the syslog file.

    Still puzzled...



  • @Merv,

    I have the same problem. It doesn't help to change the log level in the service file. It still continues dumping info about every read attempt which is annoying. I guess the "I" in the log indicates log level is Info. And it remains I whatever level you set.