unipi-kernel-modules-dkms 1.108 breaks the system on kernel 5.10.103-v7+



  • Hello,

    I upgraded unipi-kernel-modules-dkms to v 1.108 and my system broke with the latest default raspbian os kernel 5.10.103

    If the package is incompatible with kernels < 5.13 as I am guessing, you should at least add a "Conflicts" or "Requires" version on the package.

    Reverting to 1.106 seems to resolve the issue.

    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC2 Not Correct: 01c4 COMPUTED: d2ee
    [Thu Apr  7 15:52:47 2022] UNIPISPI: len=68, part1=fa:00:55:0e part2=00:00:00:00:00:00:00:00:00:00:04:04:20:03:00:00
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC2 Not Correct: 6803 COMPUTED: d813
    [Thu Apr  7 15:52:47 2022] UNIPISPI: len=6, part1=fa:00:55:0e part2=00:00:00:04:40:00:03:68:00:00:04:04:20:03:00:00
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC1 Not Correct (Received: 0000 Calculated: fe62)
    [Thu Apr  7 15:52:47 2022] UNIPISPI: part1 47:d8:00:00
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC2 Not Correct: 0000 COMPUTED: fa95
    [Thu Apr  7 15:52:47 2022] UNIPISPI: len=6, part1=fa:00:55:0e part2=00:00:00:01:01:10:00:00:00:00:04:04:20:03:00:00
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC1 Not Correct (Received: 0000 Calculated: 2c31)
    [Thu Apr  7 15:52:47 2022] UNIPISPI: part1 da:01:d4:78
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC2 Not Correct: 2002 COMPUTED: 8293
    [Thu Apr  7 15:52:47 2022] UNIPISPI: len=6, part1=fa:00:55:0e part2=00:00:00:00:00:02:02:20:11:03:10:00:10:00:63:88
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC1 Not Correct (Received: 04cb Calculated: 6980)
    [Thu Apr  7 15:52:47 2022] UNIPISPI: part1 00:0f:00:31
    [Thu Apr  7 15:52:47 2022] UNIPISPI: SPI CRC2 Not Correct: 8000 COMPUTED: 4113
    [Thu Apr  7 15:52:47 2022] UNIPISPI: len=6, part1=fa:00:55:0e part2=00:00:00:00:00:22:00:80:11:03:10:00:10:00:63:88
    [Thu Apr  7 15:52:48 2022] UNIPISPI: SPI CRC2 Not Correct: 00fa COMPUTED: 0d92
    [Thu Apr  7 15:52:48 2022] UNIPISPI: len=6, part1=fa:00:55:0e part2=00:00:00:00:40:41:fa:00:00:00:04:04:20:03:00:00
    [Thu Apr  7 15:52:48 2022] UNIPISPI: SPI CRC1 Not Correct (Received: e8e8 Calculated: 34c2)
    [Thu Apr  7 15:52:48 2022] UNIPISPI: part1 00:02:20:fa
    [Thu Apr  7 15:52:48 2022] UNIPISPI: SPI CRC2 Not Correct: 06d0 COMPUTED: 871f
    [Thu Apr  7 15:52:48 2022] UNIPISPI: len=6, part1=fa:00:55:0e part2=00:00:00:02:02:0f:d0:06:00:00:04:04:20:03:00:00
    [Thu Apr  7 15:52:48 2022] UNIPISPI: SPI CRC2 Not Correct: 0820 COMPUTED: ded2
    [Thu Apr  7 15:52:48 2022] UNIPISPI: len=68, part1=fa:00:55:0e part2=00:00:00:00:00:00:00:00:00:00:20:21:00:18:00:00
    [Thu Apr  7 15:52:48 2022] UNIPISPI: SPI CRC1 Not Correct (Received: 0000 Calculated: 0358)
    [Thu Apr  7 15:52:48 2022] UNIPISPI: part1 0e:00:00:00
    [Thu Apr  7 15:52:48 2022] UNIPISPI: SPI CRC2 Not Correct: 8018 COMPUTED: 51e9
    [Thu Apr  7 15:52:48 2022] UNIPISPI: len=68, part1=fa:00:55:0e part2=00:00:00:00:00:00:00:00:00:00:00:80:84:00:60:00```


  • @Achilleas-Kotsis

    Thanks for your hints about downgrading. Worked for me, too.

    For reference the commands here:

    apt install unipi-kernel-modules=1.106.1.20220308~buster-1

    I got the version by apt-cache policy unipi-kernel-modules.

    /KNEBB


Log in to reply