EVOK shows no I/O - Neuron L513

  • Hello,

    I bought an unused Neuron L513 (Serial-Number: 1) and I want now to test the EVOK control panel. I started with a fresh Pi OS "Buster" and installed the EVOK like it shown in the documentation. But when I start the web frontend the control panel shows only the "Analog Input 1.01" - no further entries on in- or output. Them same at system.


    EVOK service ist running. What did I wrong?



  • Hi Negropo,

    Can you enable debug logging in the /etc/evok.conf and check the /var/log/evok.log file after restarting the service? Even though you're on a totally different platform, this looks like a similar problem as what I ran into yesterday as well: https://forum.unipi.technology/topic/1124/unipi-1-1-raspberry-pi-4-buster-evok-node-red

    Kind regards,

  • Hello @marioverhaeg,

    here ist my evok.log with debug=on. Evertything seems fine, but it still won't work. I only see Analog Input & Output from 1.01.


    I also made a snapshot from my evok.conf


    And as I saw it on your post made an output from dpkg -l | egrep "raspberrypi|evok|unipi|python"

    Output dpkg

    Maybe @Martin-Kudláček could help me too?

    Kind regards

  • administrators

    Hello @marioverhaeg,

    sorry for the very late reply. Have you already solved the issue? If so, can you please share the solution?

    Thank you so much!

  • Hello @martin_triska,

    unfortunately my problem isn't solved. I think there is an programming error or a hardware malfunction. Everytime I try an http://ip-neuron/rest/all I get an error "SyntaxError: JSON.parse: unexpected character at line 1 column 5827 of the JSON data".

    I use the FHEM module for Neuron and can add manually the devices. After adding a relay in FHEM an switch them. The relay is also shown in the EVOK Control Panel. Saving the current state in flash isn't working too. When I restart/reboot the Neuron all manual added inputs, outputs etc. are gone and I just see only AI 1_01 and AO 1_01 like in my first post.

    I also tried to communicate via Modbus. It worked as long as I didn't restart/reboot the Neuron. Afterwards I have the same behaviour like described above.

    I use the latest Neuron-OS-Image from 21.12.2021. The installing process of OS and EVOK was without any error.

    For now I can't use my Neuron because it's to unsafe for loosing all devices after a reboot oder repower.

    Maybe this further information may help you to give me an advice.

    Thank you and a I wish you a happy new year!

    Kind regards

  • In the event monitor of FHEM I can see also the following message when I make a "get all": "2022.01.02 14:17:08 3: Neuron (NeuronL513) error decoding response: malformed JSON string, neither tag, array, object, number, string or atom, at character offset 5830 (before "NaN, "circuit": "3_0...") at ./FHEM/00_Neuron.pm line 424." As I can see the error occurs on AI 3_01 or an other till AI 3_04.

Log in to reply