Unipi 1.1 and Node-Red, Not working?



  • Good Evening all.

    New to the Unipi 1.1, I've downloaded and installed the Node-Red / Unipi image and now have the preloaded example flows, the Digital inputs seem to work, but the Relay outputs don't work, also the the EVOK webpage doesnt seem to update properly ie dosen't list the Relays or any connected 1wire devices.

    I followed a few tutorials, but cant find what i must be missing, any ideas?

    Cheers.


  • administrators

    Hello @DAWaller,
    I just tested the latest Unipi 1.1 Node-RED OS image (unipi1-node-red_image-20210401.0.zip) and it works. Both the Evok and the Node-RED shows the relays. Do you use the image version mentioned above?

    Best regards,
    Martin



  • Hi Thankyou for your reply.

    Yeah that was the one i'd tried, I have since redownloaded and reinstalled, this time though it seemed to work! I've managed some basic Flows and have been able to read a 1 wire sensor.

    However after a couple of reboots, seems to now have lost connectivity again, getting

    "An error occurred while sending: Error: WebSocket is not open: readyState 3 (CLOSED)"

    in the debug, Just about to try another card incase there's an issue with this one, will report back....



  • Update,

    Since reinistalling on a new card, all seems well, its been running all weekend, with a few reboots and still ok.

    I also moved the 1st SD card to another Raspberry Pi to test an LCD display and have issues with that too, which tried another - and all ok - guess i'll blame the SD card for both issues.

    Cheers for your help.


Log in to reply