Attach PLC via UDP broadcast not finding Axon M525 (after other problems)

  • I've been having problems with a new Axon M525. It initially wasn't showing up in mDNS/avahi/Bonjour, so I tried flashing it via the web service interface. That failed and the web interface stopped working, so I flashed it with a USB drive, which succeeded. It now shows up in mDNS and I can access the HMI, but Mervis does not find it when using the Attach PLC - UDP broadcast. I can find the two M505s I have on the same network.

    I have tried attaching with both Mervis 2.1.3 and 2.2.0. I believe the USB drive I flashed with had v1.9 on it.

  • administrators

    Hi @Matt,
    please use the appropriate version of the image. It should work with the image 1.9, but for the Mervis 2.2.x use the 2.2.x image:

  • FYI, it looks like OS 2.2 just doesn't have mDNS/avahi enabled. I've tried it on the M525 and an M505. I was on a different network so I was trying to find the IP address with avahi, and then resorted straight to flashing it when I couldn't find it.

    It looks like IDE 2.1.3 doesn't support the M525. I've got a solution with two existing M505s I wanted to add it to but it doesn't even show up as an option in the manual device list. Do I have to upgrade my solution to IDE 2.2.0 to add the M525? It looks like this will require me to upgrade the OS on the M505s (from 1.9), correct?

Log in to reply