I2C working, but disabled on Raspbian



  • Hi,
    I've noticed that after installing EVOK, I2C is disabled on Raspbian, but still I can communicate with I2C devices.

    I2C disabled in RP4 settings:
    a0d361b2-071d-4c79-b8c6-82533d9e790e-image.png

    I2C devices:

    i2cdetect -y 1
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
    00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
    10: -- -- -- -- -- -- -- -- 18 -- -- -- -- -- -- -- 
    20: 20 -- -- 23 -- -- -- -- -- -- -- -- -- -- -- -- 
    30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    50: 50 -- -- -- -- -- -- 57 -- -- -- -- 5c -- -- -- 
    60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- UU 
    70: -- -- -- -- -- -- -- -- 
    

    I wonder how this is possible. Is there some electronic element, which is handing I2C communication on UniPi 1.1? If yes, what is default speed of it?


  • administrators

    Hi @mglowinski,
    the I2C is enabled in a standard way by device tree overlays. The tool you are using (Raspberry Pi Configuration) probably expects the settings in their own way and don't understand the ours.



  • @Martin-Kudláček Do you maybe know how i can check current speed of I2C, which is set over device tree overlays?


Log in to reply