1Wire multiple sensors



  • Hi there,

    I am new to Unipi 1.1 and EVOK. I got several temp sensors (DS18B20) across my house which are connected in serial. I am using RJ45 splitter for each room and from last position it is connected to 1Wire on UniPi.

    The main problem is when I run EVOK, it will found all sensors but only for 7 sensors temp is shown. Others are N/A... It will throw me an error:

    Process OwBusDriver-1:
    Traceback (most recent call last):
    File "/usr/lib/python2.7/multiprocessing/process.py", line 267, in _bootstrap
    self.run()
    File "/opt/evok/owclient.py", line 395, in run
    mysensor.read_val_from_sens(mysensor.sens)
    File "/opt/evok/owclient.py", line 126, in read_val_from_sens
    if not (new_val == 85.0 and abs(new_val - self.value) > 2):
    TypeError: unsupported operand type(s) for -: 'float' and 'NoneType'

    Anybody occure same problem? What is the best approach to have multiple sensors on 1Wire?

    Thanks for replay. Jiri.



  • Problem solved, seemed I got one sensor on bus damaged on data wire and this caused this problem. Best Jiri.