Setting Listen Port



  • How can i set the Port in the /etc/evok.conf to :8080. In my file there is no entry for that.
    Thank's in advanced



  • How can i set the Port in the /etc/evok.conf to :8080. In my file there is no entry for that.
    Thank's in advanced



  • Hello,

    it is defined in /opt/evok/evok.py file line 48: define("port", default=80, help="run on the given port", type=int)

    I will change add an option in the conf file during the next week



  • WORKed! Fine and Thank's



  • I tried using the config file to change the port Evok was listening on and it wouldn't work. I found in the evok.py file at line 461:

    port = config.getintdef(Config, "MAIN", "port", 80)
    define ("port", default=port, help="Listening port settings", type=bool)
    

    which appears where the config sets the port but it wouldn't work. However, when I changed it to:

    port = config.getintdef(Config, "MAIN", "port", 80)
    define ("port", default=8181, help="Listening port settings", type=bool)
    

    it worked fine. Any ideas?



  • Try```
    sudo nano /etc/evok.conf