Can't install Evok



  • I'm new in the world of home automation and I try to get the UniPi up and running. First I downloaded the 2015-02-16-raspbian-wheezy.

    Download and unzip worked fine:
    wget https://api.github.com/repos/UniPiTechn ... all/master
    unzip master
    cd UniPiTechnology-evok-xxxxxxx

    But now when I try to run the installation scrip ./install-evok.sh it says "permission denied" even when I run it as root.

    Please tell me what I'm doing wrong....



  • I'm new in the world of home automation and I try to get the UniPi up and running. First I downloaded the 2015-02-16-raspbian-wheezy.

    Download and unzip worked fine:
    wget https://api.github.com/repos/UniPiTechn ... all/master
    unzip master
    cd UniPiTechnology-evok-xxxxxxx

    But now when I try to run the installation scrip ./install-evok.sh it says "permission denied" even when I run it as root.

    Please tell me what I'm doing wrong....



  • Hello,

    you also need to set the file executable flag by chmod +x install-evok.sh

    Than it will work. Thanks for the tip, I will fix it.

    Br,
    Tomas



  • Thanks Tomas,

    Install workt this way. All inputs and outputs are available in the web interface. I can switch the relais on and off. The only thing is that I don't see the 1-wire temperature sensor. Any suggestions?

    Berko



  • Hello Berko,

    that is just weird. We are testing all boards before it leaves so it should be ok.. However there might be a problem with the RJ45 connector on the temperature sensor. Is it possible for you to cut off the connector and make a new one? If not let me know and we will send you a new one.

    Best regards,
    Tomas



  • Hi Thomas,

    This afternoon the sensor showed up. So now I know everything is working. Because I installed a lot of things the last couple of day's I wanted to make a fresh install. Installed Weezy again, update and upgrade. Installed Evok. Unfortunately I dont see any relais anymore….

    Do I have to install another library?

    Berko



  • Hi Thomas,

    I used the Domoticz image and installed EVOk with succes. Is it possible to use a perl script to activate the relays? Or is there another way to interact with them?

    Berko



  • Hello,

    I have updated the github readme file with a simple Perl script to control relays over the JSON RPC. However websocket client is also available for Perl… See the redme

    Regards,
    Tomas