Installation problem

  • I'm trying to install EVOK on my Rasp with Jessie, but the installation fails. I have pinpointed the error to the line:

    sudo systemctl enable pigpiod

    Gives the error:
    Failed to execute operation: No such file or directory

    I believe it is typo error in the install script. It should be

    systemctl enable pigpio

    since the file name is /etc/systemd/system/pigpio.service. However, changing the name will just return another error:
    Failed to execute operation: Invalid argument

    The next line in the install script:

    systemctl enable evok

    throws exactly the same error:
    Failed to execute operation: Invalid argument

    I must admit I'm not that familiar with systemctl and this way to install services, so I might have missed something important. But obviously the install script fails on those lines.

    Any help on this?

  • I solved it myself. The installation script does not work for Jessie. I had to change the file and use the init.d scripts instead of the systemctl commands.

    cp etc/init.d/evok /etc/init.d/
    cp etc/init.d/pigpiod /etc/init.d/
    chmod +x /etc/init.d/evok
    chmod +x /etc/init.d/pigpiod
    update-rc.d pigpiod defaults
    update-rc.d evok defaults

    This works fine!

  • administrators

    Thanks for the report. I will take a look at it :)

Log in to reply