Digital input not detected



  • Hello,

    We're using your Unipi board, all is connected and configured as per your documentation.
    In the photograph please see the test set up. On the Pi side of the optocoupler we expect to receive a high voltage at the on led. We get nothing. Please help if you can.
    We can phone you if you give us your details.

    Thanks.

    [attachment=0:3jh0xxu2]unipi_digin_fault (Medium).jpg[/attachment:3jh0xxu2]



  • Hello,

    We're using your Unipi board, all is connected and configured as per your documentation.
    In the photograph please see the test set up. On the Pi side of the optocoupler we expect to receive a high voltage at the on led. We get nothing. Please help if you can.
    We can phone you if you give us your details.

    Thanks.

    [attachment=0:3jh0xxu2]unipi_digin_fault (Medium).jpg[/attachment:3jh0xxu2]



  • Hello,

    have you enabled software pull-up resistors on the GPIOs? It needs to be done in order to make it work as described in this picture[attachment=0:3spznutf]GPIO-Input-Circuit2.gif[/attachment:3spznutf]



  • That did the trick.

    Thanks!



  • Doesn't EVOK set the GPIO pull-up resistors for the digital inputs? I am testing the UniPi analog input with a pressure sensor using the "UniPi control panel" and it works perfectly. However the control panel says Input 7 is on, but nothing is connected to any of the digital inputs and the led on input 7 is not lit. I have tried rebooting, power cycling, and disconnecting the analog input, but it still says Input 7 is on. Any ideas?



  • Did you make a clean installation of raspbian? Evok sets the pullup on startup but if there is another app using that gpio it may cause such troubles.
    Second idea might be to check the cable between unipi and rpi if there are no shortcuts…



  • You got it. I had a PiFace connected to this PI previously and didn't disable the SPI bus when I removed it. As you know, it's clock is on GPIO 11 (I07). I disabled the SPI, but it still didn't work. I found a forum on line that says you have to disable it twice before the GPIO pins it uses are freed up. Did it twice and now it works! Thanks for the help.



  • Thank you! I was afraid my hardware was maybe broken http://unipi.technology/forum/viewtopic.php?f=14&t=216 but disabling SPI via

    sudo raspi-config
    
    ```> advanced options
    did the trick!


  • Thought my hardware was broke too. Happy to have helped!