Error: evok.py is not running … failed!



  • Hi Everyone,

    I got my UniPi yesterday, popped in a CR2032 battery. copied over the latest Raspbian image, ran all the steps as stated in Wiki and have now encountered the following error when starting the evok service:
    pi@unipi ~ $ sudo service evok start
    [ ok ] Starting evok daemon:.
    pi@unipi ~ $ sudo service evok status
    [FAIL] /opt/evok/evok.py is not running … failed!
    pi@unipi ~ $

    Just for fun, when I try going to http://my.pi.ip.address (in my case http://10.0.0.6) the page is not available (which makes sense)

    Any ideas why? has anyone else encountered this issue?

    Thanks for any help!

    PS: when running: sudo python /opt/evok/evok.py I'm able to reach the webpage as shown below

    ZDV



  • Hi Everyone,

    I got my UniPi yesterday, popped in a CR2032 battery. copied over the latest Raspbian image, ran all the steps as stated in Wiki and have now encountered the following error when starting the evok service:
    pi@unipi ~ $ sudo service evok start
    [ ok ] Starting evok daemon:.
    pi@unipi ~ $ sudo service evok status
    [FAIL] /opt/evok/evok.py is not running … failed!
    pi@unipi ~ $

    Just for fun, when I try going to http://my.pi.ip.address (in my case http://10.0.0.6) the page is not available (which makes sense)

    Any ideas why? has anyone else encountered this issue?

    Thanks for any help!

    PS: when running: sudo python /opt/evok/evok.py I'm able to reach the webpage as shown below

    ZDV



  • Hi,

    did you changed permission of evok.sh in /etc/init.d/ as writen ?



  • Try:
    sudo chmod 755 /opt/evok/evok.py



  • Hi,

    I have a similar Problem. evok service is not running at all. But making evok.py executable doesnt change anything. can you help me?

    /etc/initd.d/evok.py is executable:
    root@raspberrypi:~# ls -la /etc/init.d/ | grep evok
    -rwxr-xr-x 1 root root 1198 Jan 27 08:00 evok

    also under /opt/evok:
    root@raspberrypi:~# ls -la /opt/evok/
    total 160
    drwxr-xr-x 2 root root 4096 Jan 31 13:53 .
    drwxr-xr-x 8 root root 4096 Jan 26 21:23 ..
    -rwxr-xr-x 1 root root 5220 Jan 27 08:00 apigpio.py
    -rwxr-xr-x 1 root root 5793 Jan 31 13:53 apigpio.pyc
    -rwxr-xr-x 1 root root 5860 Jan 27 08:00 config.py
    -rwxr-xr-x 1 root root 3954 Jan 31 13:53 config.pyc
    -rwxr-xr-x 1 root root 781 Jan 27 08:00 devents.py
    -rwxr-xr-x 1 root root 1124 Jan 31 13:53 devents.pyc
    -rwxr-xr-x 1 root root 2186 Jan 27 08:00 devices.py
    -rwxr-xr-x 1 root root 2782 Jan 31 13:53 devices.pyc
    -rwxr-xr-x 1 root root 14132 Jan 27 08:00 evok.py
    -rwxr-xr-x 1 root root 9030 Jan 27 08:00 extcontrols.py
    -rwxr-xr-x 1 root root 10627 Jan 31 13:53 extcontrols.pyc
    -rwxr-xr-x 1 root root 10112 Jan 27 08:00 owclient.py
    -rwxr-xr-x 1 root root 10147 Jan 31 13:53 owclient.pyc
    -rwxr-xr-x 1 root root 1837 Jan 27 08:00 uninstall-evok.sh
    -rwxr-xr-x 1 root root 18040 Jan 27 08:00 unipig.py
    -rwxr-xr-x 1 root root 17012 Jan 31 13:53 unipig.pyc
    root@raspberrypi:~#

    regards
    Marlon



  • when I run /opt/evok/evok.py I get the following error message but I dont know what to do:

    root@raspberrypi:~# /opt/evok/evok.py
    Traceback (most recent call last):
    File "/opt/evok/evok.py", line 439, in <module>
    main()
    File "/opt/evok/evok.py", line 389, in main
    httpServer.listen(options.port)
    File "/usr/local/lib/python2.7/dist-packages/tornado/tcpserver.py", line 125, in listen
    sockets = bind_sockets(port, address=address)
    File "/usr/local/lib/python2.7/dist-packages/tornado/netutil.py", line 145, in bind_sockets
    sock.bind(sockaddr)
    File "/usr/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
    socket.error: [Errno 98] Address already in use
    root@raspberrypi:~#



  • Hello marlon,

    the message "socket.error: [Errno 98] Address already in use" means that the port 80 (for web) is already in use. Try changing the listening port from 80 to e.g. 8080 in /etc/evok.conf

    Do not forget put a proper addres in the url (http://your.pi:8080/)