Extension xG18 on a Neuron failed, missing xG18.yaml?



  • I tried to connect a xG18 over Modbus to my Neuron L503

    First I updated Evok to 2.2.2, then I modified the /etc/evok.conf as follow:

    ; Konfiguration Brennerei
    
    [EXTENSION_1]
    global_id = 2                                                  ; Mandatory, REQUIRED TO BE UNIQUE
    device_name = xG18                                             ; Mandatory
    modbus_uart_port = /dev/extcomm/0/0                            ; Mandatory
    ;neuron_uart_circuit = 1_01                             ; Optional, allows associating extensions with specific Neuron UART-over-Modbus ports (not possible for non-Modbus UART ports, e.g. /dev/ttyUSB0 or /d$
    ;allow_register_access = True                   ; Optional, False default, is mandatory with third-party devices
    address = 6                                                    ; Optional, 1 default
    ;scan_frequency = 10                                    ; Optional, 10 default, scanning frequency in [Hz]
    ;scan_enabled = True                                    ; Optional, True default
    ; Note that the following settings will be inherited by other devices sharing the same port, i.e. /dev/extcomm/0/0
    ;baud_rate = 19200                                              ; Optional, NEEDS UNIPI IMAGE TO WORK WITH UNIPI SERIAL PORTS! USE API TO CONFIGURE UART MANUALLY IF USING STANDARD RASPBIAN
    :parity = N                                                             ; Optional, NEEDS UNIPI IMAGE TO WORK WITH UNIPI SERIAL PORTS! USE API TO CONFIGURE UART MANUALLY IF USING STANDARD RASPBIAN
    ;stop_bits = 1
    
    

    And made the UART settings over the Evok webfrontend:

    aa8837e3-0c87-4d3c-abbe-f0e51f7b9dbb-grafik.png

    I think, I put also the DIP switches on the xG18 to the right positions, witch are 011001 (Adress. 6; 19200bps;N)

    But now I find out that the file xG18.yaml is missing in the /etc/hwdefinitions directory. Could this be the problem?
    I didn't found it on Github.

    Kind regards Stefan


  • administrators

    Hello @Stoeffel,
    the xG18 is not yet supported in the current version of Evok. We will publish the new version of Evok today or tommorow. I'll let you know, once it is out.

    Thank you for understanding and have a nice day,
    Martin



  • Hello @Martin-Kudláček
    Thanks for your information. Then I will be patient a little longer.
    I would like to ask you if adding the ID's of the 1 Wire temperature sensors to evok.conf has any performance advantages.
    I have been trying to work on my distillery control for some time now. I have 18 pc. DS18B20 sensors on the 1 Wire bus. The update time of the sensors is sometimes not fast enough or not reliable. With a script I do a reset of the 1Wire bus every 2 minutes.

    #!/bin/sh
    while sleep 120; do
    echo start mpoll 'date' 
    mbpoll -m tcp -a 0 127.0.0.1 -t 0 -0 -r 1001 1 && mbpoll -m tcp -a 0 127.0.0.1 -t 0 -0 -r 1001 0
    done
    
    

    So the bus now runs reliably, but it cannot be a permanent solution. So I thought I would switch to the Modbus and use the DS1820 with the xG18 extension. I hope we have a reliable solution.

    7b8ab249-6ca8-4606-8970-f882991e5b44-grafik.png


  • administrators

    Hello @Stoeffel,
    the Evok 2.3.0 with support for xG18 has been released. You can proceed with the apt update && apt install evok.

    Using the xG18 is definitely more stable. Each sensor has its own dedicated port and the powering of the sensors is parasitic, which ensures that the sensor will lose the power and "reset" itself after each reading. Another great advantage is that you don't need to configure the IDs of the sensors, so replacement is very quick.

    Best regards,
    Martin



  • Thank you very much Martin
    Update to evok 2.3.0 is done now. The xG18.yaml is now under /etc/hwdefinitions/
    The xG18 extension is connected. The RS485 bus also A-A and B-B. I made all settings via the DIP switches and configured the evok.conf. (as already described above ). Unfortunately I have no connection and the rx tx LED's are not flashing. Do I still have to configure the Modbus on the unipi?
    Greetings Stefan


  • administrators

    Hello @Stoeffel,

    please try to uncomment following lines in the evok.conf within the xG18 section:

    • allow_register_access
    • scan_frequency
    • scan_enabled

    In case of no success, you can try to "hardcode" the serial line parameters (baud rate, parity, stop_bits) in the config file (by uncommenting appropriate lines).



  • Hello Martin

    I'm a little further along.
    The extension is now recognized in the EVOK frontend.
    06b42ee6-6f5d-4c04-b3b0-297a0c0cba23-grafik.png
    But I don't have any Inputs on EVOK in the section:
    ef502caf-a79f-44c2-804f-2413bb6620c7-grafik.png
    Also the tx/rx led's do not blink.
    I tried with several settings, but nothing works already until now.



  • So. Now I solved the problem:
    After a

    sudo apt-get remove --purge evok && sudo apt-get update && sudo apt-get upgrade && sudo apt-get install evok
    
    

    and with this new configuration in the evok.conf I got it:

    [EXTENSION_1]
    global_id = 2                                   ; Mandatory, REQUIRED TO BE UNIQUE
    device_name = xG18                                 ; Mandatory
    modbus_uart_port = /dev/extcomm/0/0            ; Mandatory
    ;neuron_uart_circuit = 1_01                   ; Optional
    allow_register_access = True               ; Optional
    address = 1                                           ; Optional, 
    scan_frequency = 10                            ; Optional, 
    scan_enabled = True                            ; Optional, 
    ;baud_rate = 19200                              ; Optional
    ;parity = N                                             ; Optional,
    ;stop_bits = 1                                        ; Optional
    

Log in to reply